Bug 75071 - bad: mounting cdrom drive crashes computer
bad: mounting cdrom drive crashes computer
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 23:29 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:31:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-03 23:29:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
bad:manually and auto mounting my cdrom drive hangs the system, mounts on
/dev/cdrom or /dev/sd0 displays info about cdburner, then hangs
cdburner is a plexter 6x2x36 eide drive
bad: cdrom drive doesn't work at all

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. put cdrom in drive
2. mount /mnt/cdrom
3. system hangs

	

Actual Results:  it crashes, totally locks up keyboard after 10 seconds

Expected Results:  it should mount the drive

Additional info:

email lord_of_cynicism@hotmail.com and i'll let you ssh me and see for yourself
the drive worked fine in 7.3 mounted, burned cds
Comment 1 Sean Lynn 2002-11-04 11:40:11 EST
Have the same problem, thus making it reproducable!

The drive is a LiteOn 40x12x48 CDRW on hardware list.  Works as an IDE drive -
as hdd.  As SCSI emulated drive I can eject it or use cdrecord and Xcdroast, but
mounting the drive hangs the entire system - no ctrl-alt-del, ctrl-f1...  Only a
hard reset get the system working again.

Steps to Reproduce:
1. put hdd=ide-scsi into menu.lst at end of kernel line
2. update modules.conf

   options ide-cd ignore=hdd
   alias scd0 sr_mod
   pre-install sg     modprobe ide-scsi 
   pre-install sr_mod modprobe ide-scsi 
   pre-install ide-scsi modprobe ide-cd 

3. reboot
4. update fstab

   /dev/scd0   /mnt/cdrom1   iso9660 noauto,owner,kudzu,ro 0 0

5. cdrecord -scanbus (shows the drive as ok)
6. eject /dev/scd0 (this works)
7. cdrecord -scanbus (this works)
8. Xcdroast works burning

9. mount -t iso9660 /dev/scd0 /mnt/cdrom1 (hangs system)
10. mount /dev/scd0 /mnt/cdrom1 (hangs system)


Have also tried the following variations:

1. change device to sr0.  This works to eject, burn, etc..., but freezes the
system upon mount.
2. since this is the slave on the ide I changed both drives to scsi emulation. 
This means both cds (the other a Mitsumi CDROM) freeze the system.

Sean
newlife@indra.com
Comment 2 Sean Lynn 2002-11-05 18:44:46 EST
Found a workaround!

Finally got the burner working in RH 8.0!  Bug reporter lord_of_cynicism
initally gave me a workaround which I simpliefied.

As an FYI, my burner is /dev/hdd (a LiteOn 40x12x48) which I installed AFTER
RH8.0 and all I did to finally get the thing working is:

1. put hdd=scsi-ide into grub/menu.lst
2. put hdparm -c1 -d0 /dev/hdd into rc.d/rc.local to turn off dma
3. change fstab to point /dev/scd0 /mnt/cdrw
4. reboot

Everything works fine.  Have done normal read-only mount as well as read-write
operations via xcdroast and cdrecord.  I found no need to totally deactivate dma
on all ide and then reactivate it later.  Nor did I find need to run through
most of the device creation and modules.conf additions as found in CD-Writing
HOWTO. 

The only bummer (I think) is that shutting off dma requires more processor
crunching, which meant that reading a img file used about 85% of my processor. 
But, the thing works!

If anybody had more information on this (ie. w/o turning off dma) please let me
know.

Perhaps some of this information will be of use to you.

Sean
Comment 3 Bill Nottingham 2006-08-07 15:06:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 12:31:53 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.