Bug 75104 - SMB browking in konqueror fails
SMB browking in konqueror fails
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 11:53 EDT by Paul Black
Modified: 2007-04-18 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-03 08:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2002-10-04 11:53:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Accessing a Samba or Windows share in konqueror causes it to ask for username
and password then to sit there with its wheel spinning. It hasn't locked up as
the menu and buttons still work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type in smb://mars/home in the location bar
2. Enter username and password.


Actual Results:  Konqueror waits with its gear wheel spinning.

Expected Results:  A list of files from the share should've been displayed.

Additional info:

The following processes are started by konqueror:

kdeinit: kio_smb smb /tmp/ksocket-paul/klauncherKDq6hb.slave-socket
/tmp/ksocket-paul/konqueroroVk8fc.slave-socket
/usr/bin/smbclient //mars/home -Upaul
Comment 1 Need Real Name 2002-10-07 22:46:39 EDT
I have the same problem. Nautilus does NOT have the same problem.
Comment 2 Need Real Name 2002-10-10 10:22:05 EDT
Well, I experience the same kind of problem with Nautilus. I cannot open share
directories...
This makes me believe that this neither a nautilus or a konqueror problem but a
problem with samba, somehow.

Daniel
Comment 3 mxkennedy 2002-10-21 02:38:43 EDT
I also am having this problem accessing smb shares directly in Konqueror.   
You can mount it in terminal mode and choose show navigation window (F9)  
and navigate to the directory you mounted it as, ie /mnt/sambashare. 
 
 
 
Comment 4 Jason McCormick 2002-10-31 21:25:51 EST
I have also had this problem.  I've been a longtime RH and Samba user and
haven't run into this problem with KDE before.  There's a two-forked problem
from what I see.  

  The first is that the ability to set what user that Konquerer attaches to the
Windows/Samba network as has been remove from Control Center.  In vanilla KDE,
there's an option under Network in the Control Center.  This has been removed
for some unknown reason.  The file that controls who you login to SMB shares is
~/.kde/share/config/kioslaverc.  The section for hand-editing is:


[Browser Settings/SMBro]
Password={ENCRYPTED STRING}
ShowHiddenShares=true
User={USERNAME}
Workgroup={WORKGROUP)

obvious replacing the {} items with real values.  I'm not sure what encryption
method is used for Password= but copying an identical file from another KDE
installation that allows this option to be set appears to fix the login problem
with the box constantly popping up.

The second is that shares are not appearing.  I'm seeing identical results to
what the original opener of this bug posted.  I get Konq opening a window and
then the gear spinning and spinning but nothing every appearing.  Konq isn't
locked up, just never displays anything.  I won't repost a Bugzilla-helper style
report because it'd just be a repeat of the original poster.

IMHO, this should be a higher-than-normal priority because this is a CRITICAL
feature for me as I'm in a mixed enviornment as is most people using the product.
Comment 5 Jason McCormick 2002-10-31 21:28:17 EST
  As a follow-up to my previous comment, my Samba works fine because smbclient
and smbmount work by hand.
Comment 6 Need Real Name 2002-11-26 01:18:51 EST
This problem appears to be erratic in nature. Agreed, Samba works fine using
smbclient etc, but working through Konq and Nautilus, I get share display
problems. However, after several installs, I've noticed that sometimes it works
and sometimes it doesn't. THIS IS A CRUCIAL PROBLEM. Previous versions of
KDE/Gnome have worked fine in this regard. I am trying to implement RH
organisation wide in a K12 environment, and am severly limited by this bug.
HELP!!!
Comment 7 Need Real Name 2002-11-27 02:46:51 EST
I've just upgraded a machine from 7.3 to 8.0 and hey presto - Konqueror and 
Nautilius are smb'ing just fine. Work this one out!
Comment 8 Ngo Than 2002-11-27 08:26:44 EST
jason@ironlizard.org: Do you know which option under Network in the Control
Center is missing ?

Does it work in 3.0.5 in rawhide?
Comment 9 Jason McCormick 2002-11-27 12:13:55 EST
than@redhat: The option was 'windows shares' and it let you set your SMB
username and password.  It was in Control Center under the Network branch of the
tree.

I'm downloading 3.0.5 from RawHide now but I can't seem to find a fast mirror.
Is there one you're aware of?  I've got a 4-5 hour wait for the current feed I'm on.
Comment 10 Jason McCormick 2002-11-27 21:15:28 EST
Upgraded to 3.0.5 (and a bunch of other stuff since 3.0.5 required an amazing
amount of packages) and the "Windows Shares" item in Control Panel is not there
nor does it appear to open windows shares on other machines.  Konqueror can talk
to LISA and get the machine but when you open the share, Konqueror runs and runs
and never displays the files.

  On a related note, konsole appears to be broken now in 3.0.5 from rawhide....
Comment 11 Ngo Than 2002-11-28 06:46:04 EST
konsole bug was fixed in kdebase-3.0.5-4 or newer.
Comment 12 Jason McCormick 2003-01-24 15:02:51 EST
  After a long haitas looking at other things, I've returned to this issue.  For
an unkown reason, I can't get 8.0.92 to install over my local workstation.  Not
wanting to wipe and reload the box, I turned to rawhide packages.  I'm now on
the KDE 3.1 that exists in Rawhide (kdebase-3.1-0.14 and kdelibs-3.1-0.12) and
SMB browsing still does not seems to work well.  I can get the shares listed
(i.e. smb://machine) but opening a share (i.e. smb://machine/share) still does
not work.  Konq. spins and spins but nothing appears.  Any thoughts?
Comment 13 Ngo Than 2003-04-03 08:43:08 EST
it's fixed in kde 3.1.1, which is available on ftp.kde.org.
Please make sure that you have to install the latest kdebase-3.1.1-0.8x.3, which
i have uploaded it on ftp.kde.org today

Note You need to log in before you can comment on or make changes to this bug.