This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 75105 - Upgrade fails with 'KeyError: kernel-smp' error
Upgrade fails with 'KeyError: kernel-smp' error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 75066 75080 75254 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 11:57 EDT by Michael Fulbright
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fulbright 2002-10-04 11:57:22 EDT
This occurs because the kernel-smp package is installed on your system, and your
processor does not have a matching kernel-smp package in Red Hat Linux 8.0.

The workaround is to boot into your existing system, remove the kernel-smp
package, and attempt the upgrade again.

NOTE: You will not have support for SMP once you upgrade.
Comment 1 Michael Fulbright 2002-10-04 11:58:13 EDT
*** Bug 75080 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2002-10-04 12:19:04 EDT
*** Bug 75066 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-10-07 16:53:37 EDT
*** Bug 75254 has been marked as a duplicate of this bug. ***
Comment 4 Marcus O. White 2002-10-09 10:18:45 EDT
Is it possible to create an smp kernel using the 2.4.18-14 src.rpm? If so, how?

Comment 5 Jeremy Katz 2002-12-05 15:38:18 EST
This is fixed in CVS
Comment 6 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 7 Brent Fox 2003-05-25 10:53:02 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.