Bug 7511 - nwsfind, ncpmount, ncpumount does not work without SUID bit
Summary: nwsfind, ncpmount, ncpumount does not work without SUID bit
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncpfs (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 6609 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-02 15:42 UTC by Milan Kerslager
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-11 21:08:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 1999-12-02 15:42:40 UTC
As I found, nwsfind (for slist & etc), ncpmount and ncpumount need SUID
bit to be set to work properly for normal users. Because this is FAQ I
think that this bit should be set on files mentioned above (in RPM
package). I already asked P. Vandrovec (the developer of ncpfs) if this is
secure and he replied that it was. He knows NWDSCanonicalizeName and
NWDSAbbreviateNamethat functions are not safe but they are not used in
these utilities. So what do you think?

Comment 1 Bill Nottingham 2000-01-11 21:08:59 UTC
*** Bug 6609 has been marked as a duplicate of this bug. ***nwsfind needs to be, and it's fixed in 2.2.0.17-1,
which will be in the next Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.