Bug 75123 - cdrecord fails when in Xwindows
cdrecord fails when in Xwindows
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 13:36 EDT by Steve Taylor
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 11:44:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (22.62 KB, text/plain)
2002-10-04 13:39 EDT, Steve Taylor
no flags Details
dmesg (6.77 KB, text/plain)
2002-10-04 13:39 EDT, Steve Taylor
no flags Details

  None (edit)
Description Steve Taylor 2002-10-04 13:36:25 EDT
Description of Problem:

cdrecord failes everytime I enter X. If I boot into runlevel 3 and do not enter
X I can burn successfully. Once I enter X something is set in play that will not
allow a good burn, even after exiting Xwindows. Everything works fine under 7.3
and AS2.1, no issues what so ever.



Version-Release number of selected component (if applicable):

cdrecord-1.10-14

How Reproducible:


Steps to Reproduce:
1. Reboot 
2. Enter X
3. Try to burn anything

Actual Results:

[root@chatak ISO]# cdrecord -v -dao speed=24 dev=0,0,0 track-01.img
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'BTC     '
Identifikation : 'BCE2410IM       '
Revision       : 'A.21'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : SWABAUDIO
Drive buf size : 924000 = 902 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  328 MB
Total size:     377 MB (37:23.84) = 168288 sectors
Lout start:     377 MB (37:25/63) = 168288 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -12369 (97:17/06)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    unknown
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 191561
Starting to write CD/DVD at speed 24 in write mode for single session.
Last chance to quit, starting real write in 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:   0 of 328 MB written.cdrecord: Input/output error. write_g1:
scsi sendcmd: no error
CDB:  2A 00 00 00 00 3E 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 71 00 05 00 00 00 00 0A 00 00 00 00 21 02 00 00
Sense Key: 0x5 Illegal Request, deferred error, Segment 0
Sense Code: 0x21 Qual 0x02 (logical block address out of range) [No
matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.121s timeout 200s

write track data: error after 126976 bytes
Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
Writing  time:   15.764s
Fixating...
Fixating time:    0.001s
cdrecord: fifo had 66 puts and 3 gets.
cdrecord: fifo was 0 times empty and 1 times full, min fill was 96%.
[root@chatak ISO]#


Expected Results:

Successfull burn


Additional Information:
	


Running 8.0 full install
Asus P2B-F
PIII 450
512 Meg Ram
hda     80gig drive
hdb     14gig drive
hdd     BCM2410IM 24x10x40 CD-RW


[root@chatak ISO]# cdrecord --scanbus
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
scsibus0:
        0,0,0     0) 'BTC     ' 'BCE2410IM       ' 'A.21' Removable
CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *


I did another test..

reboot into runlevel 3, switchdesk-helper gnome
open terminal, sudo bash, su -, then try the burn...FAILED

reboot into runlevel 3, switchdesk-helper kde
open terminal, sudo bash, su -, then try the burn...FAILED

reboot into runlevel 3, switchdesk-helper WindoMaker
open terminal, sudo bash, su -, then try the burn...Succeeded (but
buffer was as low as 20%) which is NOT normal.


[root@chatak root]# cat hdparm.txt
 HDIO_GET_MULTCOUNT failed: Input/output error
 BLKRAGET failed: Input/output error
 HDIO_GETGEO failed: Invalid argument

/dev/hdd:
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
[root@chatak root]#

[root@chatak root]# cat mtrr.before-x
reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1
[root@chatak root]#

[root@chatak root]# cat mtrr.after.startx
reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1
reg01: base=0xd8000000 (3456MB), size=  32MB: write-combining, count=1
[root@chatak root]#

[root@chatak root]# cat mtrr.after.burn-failed
reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1
reg01: base=0xd8000000 (3456MB), size=  32MB: write-combining, count=1
[root@chatak root]#

[root@chatak root]# cat lsmod
Module                  Size  Used by    Not tainted
sg                     36556   0  (autoclean)
sr_mod                 18136   0  (autoclean)
soundcore               6532   0  (autoclean)
tulip                  43552   1
iptable_filter          2412   0  (autoclean) (unused)
ip_tables              14936   1  [iptable_filter]
ide-scsi               10512   0
scsi_mod              107176   3  [sg sr_mod ide-scsi]
ide-cd                 33608   0
cdrom                  33696   0  [sr_mod ide-cd]
mousedev                5524   0
keybdev                 2976   0  (unused)
hid                    22244   0  (unused)
input                   5888   0  [mousedev keybdev hid]
usb-uhci               26188   0  (unused)
usbcore                77024   1  [hid usb-uhci]
ext3                   70368   4
jbd                    52212   4  [ext3]
[root@chatak root]#


****** created from <startx > logfile 2>&1> ******
[root@chatak root]# cat startx.log


XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window
System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.18-14
(bhcompile@stripples.devel.redhat.com) (gcc version 3.2 20020903 (Red
Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Sep 30 20:45:22 2002
(==) Using config file: "/etc/X11/XF86Config"
SESSION_MANAGER=local/chatak.linuxjunkies.net:/tmp/.ICE-unix/922
Loaded background '0x8096100
AUDIT: Mon Sep 30 20:45:35 2002: 919 X: client 5 rejected from local
host
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
FAMOpen failed, FAMErrno=0
Saving session: gnome-terminal --use-factory
--window-with-profile-internal-id=Default --show-menubar --title
root@chatak:~ --working-directory /root

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

(nautilus:975): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget,
event)' failed

waiting for X server to shut down The application 'gnome-terminal' lost
its connection to the display:0.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'gnome-panel' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.


[root@chatak root]#


****** mtrr after <echo "disable=1" > /proc/mtrr> ******
[root@chatak debug]# cat mtrr.after.disable
reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1
[root@chatak debug]#


[root@chatak debug]# cat iomem.before
00000000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000f0000-000fffff : System ROM
00100000-1fffcfff : System RAM
  00100000-0024b8dd : Kernel code
  0024b8de-003457a3 : Kernel data
1fffd000-1fffefff : ACPI Tables
1ffff000-1fffffff : ACPI Non-volatile Storage
d5000000-d50000ff : Lite-On Communications Inc LNE100TX
  d5000000-d50000ff : tulip
d5800000-d58000ff : Lite-On Communications Inc LNE100TX [Linksys
EtherFast 10/100]
  d5800000-d58000ff : tulip
d6000000-d7dfffff : PCI Bus #01
  d6000000-d6ffffff : nVidia Corporation NV11 (GeForce2 MX)
d7f00000-e3ffffff : PCI Bus #01
  d8000000-dfffffff : nVidia Corporation NV11 (GeForce2 MX)
e4000000-e7ffffff : Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
ffff0000-ffffffff : reserved
[root@chatak debug]#

[root@chatak debug]# cat iomem.after.startx
00000000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000a0000-000bffff : Video RAM area
000c0000-000c7fff : Video ROM
000f0000-000fffff : System ROM
00100000-1fffcfff : System RAM
  00100000-0024b8dd : Kernel code
  0024b8de-003457a3 : Kernel data
1fffd000-1fffefff : ACPI Tables
1ffff000-1fffffff : ACPI Non-volatile Storage
d5000000-d50000ff : Lite-On Communications Inc LNE100TX
  d5000000-d50000ff : tulip
d5800000-d58000ff : Lite-On Communications Inc LNE100TX [Linksys
EtherFast 10/100]
  d5800000-d58000ff : tulip
d6000000-d7dfffff : PCI Bus #01
  d6000000-d6ffffff : nVidia Corporation NV11 (GeForce2 MX)
d7f00000-e3ffffff : PCI Bus #01
  d8000000-dfffffff : nVidia Corporation NV11 (GeForce2 MX)
e4000000-e7ffffff : Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge
ffff0000-ffffffff : reserved
[root@chatak debug]#


[root@chatak debug]# cat ioports.before
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0cf8-0cff : PCI conf1
b000-b0ff : Lite-On Communications Inc LNE100TX
  b000-b0ff : tulip
b400-b40f : Fortemedia, Inc Xwave QS3000A [FM801 game port]
b800-b87f : Fortemedia, Inc Xwave QS3000A [FM801]
d000-d0ff : Lite-On Communications Inc LNE100TX [Linksys EtherFast
10/100]
  d000-d0ff : tulip
d400-d41f : Intel Corp. 82371AB/EB/MB PIIX4 USB
  d400-d41f : usb-uhci
d800-d80f : Intel Corp. 82371AB/EB/MB PIIX4 IDE
  d800-d807 : ide0
  d808-d80f : ide1
e400-e43f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
e800-e81f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
[root@chatak debug]#

[root@chatak debug]# cat ioports.after.startx
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(auto)
0cf8-0cff : PCI conf1
b000-b0ff : Lite-On Communications Inc LNE100TX
  b000-b0ff : tulip
b400-b40f : Fortemedia, Inc Xwave QS3000A [FM801 game port]
b800-b87f : Fortemedia, Inc Xwave QS3000A [FM801]
d000-d0ff : Lite-On Communications Inc LNE100TX [Linksys EtherFast
10/100]
  d000-d0ff : tulip
d400-d41f : Intel Corp. 82371AB/EB/MB PIIX4 USB
  d400-d41f : usb-uhci
d800-d80f : Intel Corp. 82371AB/EB/MB PIIX4 IDE
  d800-d807 : ide0
  d808-d80f : ide1
e400-e43f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
e800-e81f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
[root@chatak debug]#


[root@chatak debug]# cat cdrecord.after.mtrr
[root@chatak ISO]# cdrecord -v -dao speed=24 dev=0,0,0 track-01.img
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'BTC     '
Identifikation : 'BCE2410IM       '
Revision       : 'A.21'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : SWABAUDIO
Drive buf size : 924000 = 902 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  328 MB
Total size:     377 MB (37:23.84) = 168288 sectors
Lout start:     377 MB (37:25/63) = 168288 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type B, low Beta category (B-) (4)
  ATIP start of lead in:  -12369 (97:17/06)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    unknown
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 191561
Starting to write CD/DVD at speed 24 in write mode for single session.
Last chance to quit, starting real write in 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:   0 of 328 MB written.cdrecord: Input/output error. write_g1:
scsi sendcmd: no error
CDB:  2A 00 00 00 00 3E 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 71 00 05 00 00 00 00 0A 00 00 00 00 21 02 00 00
Sense Key: 0x5 Illegal Request, deferred error, Segment 0
Sense Code: 0x21 Qual 0x02 (logical block address out of range) [No
matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.121s timeout 200s

write track data: error after 126976 bytes
Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
Writing  time:   15.764s
Fixating...
Fixating time:    0.001s
cdrecord: fifo had 66 puts and 3 gets.
cdrecord: fifo was 0 times empty and 1 times full, min fill was 96%.
[root@chatak ISO]#

[root@chatak debug]#
Comment 1 Steve Taylor 2002-10-04 13:39:04 EDT
Created attachment 78664 [details]
X log
Comment 2 Steve Taylor 2002-10-04 13:39:43 EDT
Created attachment 78665 [details]
dmesg
Comment 3 Steve Taylor 2002-10-05 23:30:28 EDT
Did some wholesale hardware changes and its still broken in the same manor. 

Changes are listed below

Asus P2B-F  -> Asus A7V133A Latest bios 1009
PIII 450    -> 1.2 Gig 266 FSB athlon
512 Meg Ram -> 1 gig
Geforce2 MX -> Geforce3 Ti200
FM801 sound -> Sound Blaster Live

hda     80gig drive
hdc     14gig drive
hdd     BCM2410IM 24x10x40 CD-RW
Comment 4 Mike A. Harris 2002-10-07 01:23:33 EDT
What happens if you renice the X server to 0 first?

As root, do:  renice 0 $(pidof X)

Check the output of top to ensure X is running at nice of 0.  By default,
the kernel will auto-renice X to -10.  It's possible this is interfering
with burning CD's.  If so, it's a kernel issue.
Comment 5 Steve Taylor 2002-10-07 07:21:09 EDT
reniced first:

5289 root      15   0  151M  19M  7040 S     0.5  1.9  55:33 X


Burn still failed in same manor:
[root@gkar ISO]# cdrecord -v -eject speed=16 dev=0,0,0 track-01.img
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'BTC     '
Identifikation : 'BCE2410IM       '
Revision       : 'A.21'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : SWABAUDIO
Drive buf size : 924000 = 902 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  328 MB
Total size:     377 MB (37:23.86) = 168290 sectors
Lout start:     377 MB (37:25/65) = 168290 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 6
  Is not unrestricted
  Is not erasable
  ATIP start of lead in:  -12414 (97:16/36)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 68
Manufacturer: Grand Advance Technology LTD.
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 191559
Starting to write CD/DVD at speed 16 in write mode for single session.
Last chance to quit, starting real write in 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Starting new track at sector: 0
Track 01:   0 of 328 MB written.cdrecord: Input/output error. write_g1: scsi sen
dcmd: no error
CDB:  2A 00 00 00 00 9B 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 71 00 05 00 00 00 00 0A 00 00 00 00 21 02 00 00
Sense Key: 0x5 Illegal Request, deferred error, Segment 0
Sense Code: 0x21 Qual 0x02 (logical block address out of range) [No matching qua
lifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 40s

write track data: error after 317440 bytes
Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
Writing  time:   14.128s
Fixating...
cdrecord: Input/output error. close track/session: scsi sendcmd: no error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 72 03 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x72 Qual 0x03 (session fixation error - incomplete track in session
) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 480s
cmd finished after 0.000s timeout 480s
Fixating time:    0.001s
cdrecord: fifo had 69 puts and 6 gets.
cdrecord: fifo was 0 times empty and 1 times full, min fill was 92%.
[root@gkar ISO]#

check to make sure was still reniced (it was):
5289 root      15   0  151M  19M  7040 R     0.9  1.9  55:35 X
Comment 6 Steve Taylor 2002-10-07 19:14:49 EDT
Latest debug info:

Removed Geforce3 and put in a matrox G400, Still fails in the same
fashion. Here are the results:

[root@gkar ISO]# cdrecord -v -dao speed=16 dev=0,0,0 track-01.img
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'BTC     '
Identifikation : 'BCE2410IM       '
Revision       : 'A.21'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : SWABAUDIO
Drive buf size : 924000 = 902 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  328 MB
Total size:     377 MB (37:23.84) = 168288 sectors
Lout start:     377 MB (37:25/63) = 168288 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 6
  Is not unrestricted
  Is not erasable
  ATIP start of lead in:  -12414 (97:16/36)
  ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 68
Manufacturer: Grand Advance Technology LTD.
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 191561
Starting to write CD/DVD at speed 16 in write mode for single session.
Last chance to quit, starting real write in 0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:   0 of 328 MB written.cdrecord: Input/output error. write_g1:
scsi sendcmd: no error
CDB:  2A 00 00 00 00 BA 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 71 00 05 00 00 00 00 0A 00 00 00 00 21 02 00 00
Sense Key: 0x5 Illegal Request, deferred error, Segment 0
Sense Code: 0x21 Qual 0x02 (logical block address out of range) [No
matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.098s timeout 200s

write track data: error after 380928 bytes
Sense Bytes: 70 00 00 00 00 00 00 0A 00 00 00 00 00 00 00 00 00 00
Writing  time:   17.366s
Fixating...
Fixating time:    0.001s
cdrecord: fifo had 70 puts and 7 gets.
cdrecord: fifo was 0 times empty and 3 times full, min fill was 95%.
[root@gkar ISO]#

Here is some general stuff to show you a few things I've been asked
about:

LSPCI

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:04.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 06)
00:04.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:09.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100
model NC100 (rev 11)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 05)
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20265 (rev 02)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04)

LSMOD

Module                  Size  Used by    Not tainted
sg                     36556   0  (autoclean)
sr_mod                 18136   0  (autoclean)
emu10k1                68744   0  (autoclean)
ac97_codec             13384   0  (autoclean) [emu10k1]
sound                  74388   0  (autoclean) [emu10k1]
soundcore               6532   7  (autoclean) [emu10k1 sound]
tulip                  43552   1
iptable_filter          2412   0  (autoclean) (unused)
ip_tables              14936   1  [iptable_filter]
ide-scsi               10512   0
scsi_mod              107176   3  [sg sr_mod ide-scsi]
ide-cd                 33608   0
cdrom                  33696   0  [sr_mod ide-cd]
mousedev                5524   1
keybdev                 2976   0  (unused)
hid                    22244   0  (unused)
input                   5888   0  [mousedev keybdev hid]
usb-uhci               26188   0  (unused)
usbcore                77024   1  [hid usb-uhci]
ext3                   70368   3
jbd                    52212   3  [ext3]

CAT /PROC/MTRR
reg00: base=0x00000000 (   0MB), size=1024MB: write-back, count=1
reg01: base=0xe4000000 (3648MB), size=  16MB: write-combining, count=1
reg07: base=0xe6000000 (3680MB), size=  32MB: write-combining, count=1

CAT /PROC/MEMINFO
        total:    used:    free:  shared: buffers:  cached:
Mem:  1055735808 148709376 907026432        0 15089664 71389184
Swap: 1077501952        0 1077501952
MemTotal:      1030992 kB
MemFree:        885768 kB
MemShared:           0 kB
Buffers:         14736 kB
Cached:          69716 kB
SwapCached:          0 kB
Active:         101180 kB
Inact_dirty:       240 kB
Inact_clean:     21512 kB
Inact_target:    24584 kB
HighTotal:      130992 kB
HighFree:        19700 kB
LowTotal:       900000 kB
LowFree:        866068 kB
SwapTotal:     1052248 kB
SwapFree:      1052248 kB
Committed_AS:    85632 kB

PS AUX

USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  1.4  0.0  1336  476 ?        S    18:45   0:06 init
root         2  0.0  0.0     0    0 ?        SW   18:45   0:00 [keventd]
root         3  0.0  0.0     0    0 ?        SW   18:45   0:00 [kapmd]
root         4  0.0  0.0     0    0 ?        SWN  18:45   0:00 [ksoftirqd_CPU0]
root         5  0.0  0.0     0    0 ?        SW   18:45   0:00 [kswapd]
root         6  0.0  0.0     0    0 ?        SW   18:45   0:00 [bdflush]
root         7  0.0  0.0     0    0 ?        SW   18:45   0:00 [kupdated]
root         8  0.0  0.0     0    0?        SW   18:45   0:00 [mdrecoveryd]
root        12  0.0  0.0     0    0 ?        SW   18:45   0:00 [kjournald]
root        68  0.0  0.0     0    0 ?        SW   18:45   0:00 [khubd]
root       195  0.0  0.0     0    0 ?        SW   18:46   0:00 [kjournald]
root       196  0.0  0.0     0    0 ?        SW   18:46   0:00 [kjournald]
root       492  0.0  0.0  2056 1020 ?        S    18:46   0:00 /sbin/dhclient -1
root       531  0.0  0.0  1400  536 ?        S    18:46   0:00 syslogd -m 0
root       535  0.0  0.0  1336  428 ?        S    18:46   0:00 klogd -x
rpc        552  0.0  0.0  1488  536 ?        S    18:46   0:00 portmap
named      588  0.0  0.2 10732 2664 ?        S    18:46   0:00 named -u named
root       605  0.0  0.1  3276 1464 ?        S    18:46   0:00 /usr/sbin/sshd
root       616  0.0  0.0  2100  864 ?        S    18:46   0:00 xinetd -stayalive
ntp        630  0.0  0.1  1916 1908 ?        SL   18:46   0:00 ntpd -U ntp
root       643  0.0  0.1  4008 1196 ?        S    18:46   0:00 /bin/sh /usr/bin/
mysql      676  0.0  0.4 28796 4652 ?        S    18:46   0:00 /usr/libexec/mysq
root       744  0.0  0.1  3652 1168 ?        S    18:47   0:00 /usr/libexec/post
postfix    752  0.0  0.1  3732 1176 ?        S    18:47   0:00 pickup -l -t fifo
postfix    753  0.0  0.1  5080 1432 ?        S    18:47   0:00 nqmgr -l -n qmgr
root       756  0.0  0.0  1372  432 ?        S    18:47   0:00 gpm -t imps2 -m /
root       765  0.0  0.0  1516  612 ?        S    18:47   0:00 crond
xfs        838  0.0  0.4  6416 5052 ?        S    18:47   0:00 xfs -droppriv -da
root       854  0.0  0.1  2264 1036 ?        S    18:47   0:00 login -- root
root       855  0.0  0.0  1316  404 tty2     S    18:47   0:00 /sbin/mingetty tt
root       856  0.0  0.0  1316  404 tty3     S    18:47   0:00 /sbin/mingetty tt
root       857  0.0  0.0  1316  404 tty4     S    18:47   0:00 /sbin/mingetty tt
root       858  0.0  0.0  1316  404 tty5     S    18:47   0:00 /sbin/mingetty tt
root       859  0.0  0.0  1316  404 tty6     S    18:47   0:00 /sbin/mingetty tt
root       862  0.0  0.1  4208 1508 tty1     S    18:47   0:00 -bash
root      1017  0.0  0.2  3352 2124 ?        S    18:48   0:00 esd -terminate -n
root      1047  0.1  0.4  8364 4900 ?        S    18:49   0:00 /usr/libexec/gcon
root      1049  0.0  0.1  3820 1060 tty1     S    18:49   0:00 /bin/sh /usr/X11R
root      1062  0.0  0.0  2292  592 tty1     S    18:49   0:00 xinit /etc/X11/xi
root      1063  1.5  0.7 34908 7752 ?        S<   18:49   0:02 X :0
root      1066  0.1  0.8 16388 8348 tty1     S    18:49   0:00 gnome-session
root      1080  0.0  0.0  2900  992 ?        S    18:49   0:00 ssh-agent /root/.
root      1096  0.0  0.2  5592 2180 ?        S    18:49   0:00 /usr/libexec/bono
root      1098  0.1  0.6 12104 6472 ?        S    18:49   0:00 /usr/bin/metacity
root      1102  0.2  0.6 16052 7068 ?        S    18:49   0:00 gnome-settings-da
root      1110  0.4  1.0 18568 10900 ?       S    18:49   0:00 gnome-panel --sm-
root      1112  0.6  1.3 31348 13404 ?       S    18:49   0:01 nautilus --no-def
root      1114  0.0  0.5 14772 5928 ?        S    18:49   0:00 magicdev --sm-cli
root      1116  0.0  0.3 10864 4096 ?        S    18:49   0:00 pam-panel-icon --
root      1118  0.2  1.2 21984 12636 ?       S    18:49   0:00 /usr/bin/python /
root      1119  0.0  0.0  1364  472 ?        S    18:49   0:00 /sbin/pam_timesta
root      1127  0.6  0.8 17320 8812 ?        S    18:49   0:01 gnome-terminal
root      1128  0.0  0.1  4208 1536 pts/0    S    18:49   0:00 bash
root      1186  0.0  0.0  2612  696 pts/0    R    18:52   0:00 ps aux

CAT /PROC/CPUINFO
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 1208.821
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips        : 2392.13
Comment 7 Peter Smith 2002-10-08 10:10:22 EDT
Is this problem caused by X itself or something in your window manager changing
parameters/loading modules?  Have you tried creating a $HOME/.xinitrc with just
'xterm' in it, and then starting X to see if it is XFree itself or if it is the
things that load after XFree?
Comment 8 Steve Taylor 2002-10-08 11:43:59 EDT
Turns out this problem is caused by magicdev. rpm -e magicdev solved all my
problems.
Comment 9 Mike A. Harris 2002-10-26 00:40:01 EDT
Ok, closing bug NOTABUG (since reassigning it to magicdev is pointless
as everyone in the Linux community is aware of the issue widely for
years, and a solution doesn't seem forthcoming anytime soon.)

Note You need to log in before you can comment on or make changes to this bug.