Bug 75130 - Remote terminal sound no longer works.
Remote terminal sound no longer works.
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: esound (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 14:17 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 21:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-04 14:17:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
The problem is with v0.2.28.  esdplay correctly plays to a local
sound server, but no longer plays to a sound server located on a
remote host (such as an X11 terminal).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch "esd -public -tcp -nobeeps -port 16001" on a remote host
2. Go to a different host on the same network
3. Find a WAV file to play (ex. /usr/share/sounds/info.wav)
4. esdplay -s REMOTE_HOST /usr/share/sounds/info.wav


Actual Results:  At this point, nothing happens.  If esdplay is used
without the "-s" option, it plays correctly on the local host, of course.

Expected Results:  The sound should play on the remote terminal host.

Additional info:

I verified this against EsounD v0.2.27 and that works
correctly.  I also performed the following experiment:

1. Run "esd -public -tcp -nobeeps -port 16001" on a remote host,
   using v0.2.28
2. Run 'esdplay' on the other host, using v0.2.27

This works, indicating that the problem is with the client side.
The server and libraries on the remote terminal are v0.2.28 and
are responding correctly.

This bug is relatively serious, since there are large terminal
deployments that would be affected by lack of sound on the desktop.
Comment 1 Mike A. Harris 2002-12-20 00:01:11 EST
I run esd on a 7.1 box with sound hardware, and clients on a remote 8.0
box run using the ESPEAKER environment variable and work ok.  I haven't
tested the reverse though, of using esd on 8.0 and having remote clients
connect to it.  Unfortunately, my only 8.0 boxes currently do not have
sound hardware in them to test this.

If I get a chance soon, I will test this and report back.  The esd remote
feature is an extremely cool and very useful thing I stumbled upon not
long ago.  Painless network audio.  Yum yum.

Will report back on this after I've had a chance to test.
Comment 2 Havoc Pennington 2003-01-12 21:11:50 EST
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=103249

Note You need to log in before you can comment on or make changes to this bug.