Bug 75163 - logout hang and restart problems
logout hang and restart problems
Status: CLOSED DUPLICATE of bug 79829
Product: Red Hat Linux
Classification: Retired
Component: gnome-session (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-10-04 18:15 EDT by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-10-04 18:15:28 EDT
Description of Problem:
I actually saw this problem during the beta but it seemed to come and go.  In
addition, this may actually be multiple problems but it all seems related.

1.  I am running the gnome/metacity environment and "normally" have running 3
copies of gnome terminal, two copies of galeon, evolution (calendar), a couple
of open folders, and kmail.

When I login, everything starts up except kmail (it was up when I saved the
session).  If I start it, it starts immediately.

If I then logout and do so relatively soon after the login, the logout proceeds
notmall (with or without the session saving).

However, I I am logged on for awhile doing running various applications and then
try to logout, the logout hangs and I have to do a ctl-alt-backspace to get out.

Version-Release number of selected component (if applicable):
8.0

How Reproducible:
yes
Comment 1 Havoc Pennington 2002-11-05 13:13:17 EST
During the hang, which applications are still open? (All of them, or only some?
which ones if only some?)
Comment 2 Henrik Brix Andersen 2002-11-05 13:19:14 EST
I can reproduce the above problem here.
I use GNOME2/Sawfish not GNOME2/Metacity.
It seems like "logout" is waiting for some application to respond... all applications remain open while waiting for logout to take effect. Giving logout time (anything from 30 secs to 10 min) causes the logout to happen.
Comment 3 Gene Czarcinski 2002-11-05 13:55:56 EST
It especially happens when I save the session and, yes, I agree that it seems to
be wainting for something.

Generally, I have: 3 or 4 gnome-terminals, 2 galeon, kmail, and evolution. 
Sometimes, I additionally run kpat (klondike).  I am running metacity/gnome.

BTW, I found that kmail at startup has been started but takes forever to really
come up.  If I am patient enough it will finally appear.
Comment 4 Havoc Pennington 2003-01-08 00:19:21 EST
dup of bug 79829 perhaps?
Comment 5 Stefan Schwandter 2003-01-29 12:22:28 EST
I've had the same, really annoying problem, first I thought the logout was
waiting on the red hat network applet, because it always started up
simultanously to the eventual appereance of the logout screen.

I have not seen this problem since I switched to "save session automtically on
logout" or how this option is called in english (using the german version).
Comment 6 Bill Nottingham 2003-02-11 00:12:34 EST

*** This bug has been marked as a duplicate of 79829 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:49:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.