Bug 75191 - slrn not UTF-8 aware
slrn not UTF-8 aware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: slrn (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 86310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 05:15 EDT by Need Real Name
Modified: 2013-07-02 18:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 09:57:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-05 05:15:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.1) Gecko/20020826

Description of problem:
slrn is not able to display utf8 with german umlauts like |vd

If a line in the articeltext contains a german umlaut (like |vd) the rest of the
line is cutted.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start slrn
2.look for a message with an umlaut in the body
3.see it
	

Actual Results:  slrn shows a a line in the body like 
wordwordword | wordwordword 
in this way:
wordwordword

Expected Results:  slrn should display
wordwordword | wordwordword

Additional info:
Comment 1 Need Real Name 2002-10-06 05:11:33 EDT
Perhaps it is a slang-Problem (or a problem with the utf8-patch for slang)
Debian stopped to use this utf8-patch because it is to buggy. Perhaps redhat
should wait until slang2.0 with slrn + utf8.
Comment 2 Jan-Frode Myklebust 2003-01-07 05:44:23 EST
If

LANG=en_US.UTF-8

I see this same problem (or no_NO.UTF-8). If I instead use

LANG=en_US.8859-1

I get question marks wherever there should have been a Norwegian character.

Are there no workarounds for this problem?
Comment 3 Emmanuel Seyman 2003-04-18 04:45:52 EDT
Reproduced with Red Hat Linux 9 (slrn 0.9.7.4)
Comment 4 Need Real Name 2003-10-28 18:41:09 EST
This also applies to pound signs (i.e. £) in Red Hat 9, as well as having tried
the updated versions of slang (and slrn?) available from Fedora and rawhide.

It is possible to amend the slang specfile to cut out the UTF-8 patches but then
all slang-linked programs have to be recompiled.
Comment 5 John Gotts 2004-04-19 13:43:20 EDT
Leaving anything but all of the language-related variables (LANG,
LC_CTYPE, etc.) unset is too buggy to be usable.  That this bug hasn't
been fixed in over eighteen months is proof.

Red Hat's internationalization attempt here is further broken because
it ignores my wishes to completely shut it all off.

The fix is to set LANG to en_US.8859-1 as Jan-Frode mentioned before
running slrn and to set gnome-terminal to use the Western Character
Coding (Terminal->Character Coding->ISO-8859-1) to get accented
characters to display correctly.
Comment 6 Daniel Roesen 2004-08-09 14:28:33 EDT
Well, the threading tree arrows are also highly broken and mess up the
terminal when using UTF-8. Fedora Core 1 here.

Will there be anything done anymore? We don't have a single comment
from Red Hat folks since almost two years now...
Comment 7 Jindrich Novy 2005-01-09 14:30:00 EST
Hello,

I'm sorry for the ignorance. Since I'm woking in recent time at
porting of slang UTF-8 patches to the internal slang of mc, I'll try
to resolve this or at least comment out it here, because from the
comments you posted here I see it looks like pretty similar problem.

Thanks for your postings,
Jindrich
Comment 8 Daniel Roesen 2005-06-04 18:39:53 EDT
Jindrich, got any time to look at this one yet?
Comment 9 Jindrich Novy 2005-06-09 13:18:36 EDT
Hello Daniel, hopefully in the next two weeks.
Comment 10 Jindrich Novy 2005-09-08 11:11:46 EDT
*** Bug 86310 has been marked as a duplicate of this bug. ***
Comment 11 Jindrich Novy 2006-01-03 09:57:40 EST
The new slrn-0.9.8.1pl1 with native slang-2 support now works perfectly with
UTF-8. Miroslav Lichvar tested it with cyrillic text and all behaved well.

Closing rawhide.

Note You need to log in before you can comment on or make changes to this bug.