Bug 75195 - CGI.pm doesn't work with mod_perl 2
Summary: CGI.pm doesn't work with mod_perl 2
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 10:48 UTC by Ville Skyttä
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-14 02:08:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make CGI.pm work with mod_perl 2 (743 bytes, patch)
2002-10-05 10:48 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2002-10-05 10:48:10 UTC
The CGI.pm that comes with RH8 doesn't work with the shipped mod_perl-1.99_05-3.
This is a CGI.pm bug, and I've submitted a patch to the author already.

I'll attach the patch here for your convenience, it's against CGI.pm 2.86.

Comment 1 Ville Skyttä 2002-10-05 10:48:49 UTC
Created attachment 78864 [details]
Make CGI.pm work with mod_perl 2

Comment 2 Chip Turner 2002-11-05 00:00:47 UTC
*** Bug 77175 has been marked as a duplicate of this bug. ***

Comment 3 Chip Turner 2002-11-05 00:03:09 UTC
This patch is in the upstream 2.89 release; can you confirm that 2.89 unpatched
also works for you?

Comment 4 Ville Skyttä 2002-11-05 00:04:45 UTC
Yep, been using a vanilla 2.89 somewhat with mod_perl 1.99 and it seems to work
for me.


Comment 5 Chip Turner 2002-11-06 16:43:24 UTC
*** Bug 77175 has been marked as a duplicate of this bug. ***

Comment 6 Hamadoun Diall 2003-04-02 12:49:57 UTC
This bug is also reported in mod_perl's troubleshooting page 
http://perl.apache.org/docs/2.0/user/troubleshooting/troubleshooting.html#Error_
about_not_finding_I_Apache_pm__with_I_CGI_pm_

"You need to install at least version 2.87 of CGI.pm to work under mod_perl 
2.0, as earlier CGI.pm versions aren't mod_perl 2.0 aware"

I've searched in the latest Raw Hide RPMs, as well as the RHL 9 package list, 
and perl-CGI 2.81 is still the only one available... Is a 2.87 (or higher) 
version of this package to be expected anytime soon in the Red Hat distro?

Thanks in advance.

Comment 7 Chip Turner 2004-02-14 02:08:46 UTC
the perl in rawhide includes CGI.pm 3.01 which should resolve this


Note You need to log in before you can comment on or make changes to this bug.