Bug 751982 - [abrt] libreoffice-core-3.4.3.2-15.fc16: shadowed m_aXineramaScreenIndexMap crash on multihead new display added
[abrt] libreoffice-core-3.4.3.2-15.fc16: shadowed m_aXineramaScreenIndexMap c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:f72226c6b9a0d93f505e63f0a90...
:
: 755389 (view as bug list)
Depends On: 743750
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 03:38 EST by Jan Kratochvil
Modified: 2011-11-23 10:40 EST (History)
9 users (show)

See Also:
Fixed In Version: libreoffice-3.4.4.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-15 19:30:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (18.32 KB, text/plain)
2011-11-08 03:38 EST, Jan Kratochvil
no flags Details
File: build_ids (6.69 KB, text/plain)
2011-11-08 03:38 EST, Jan Kratochvil
no flags Details
File: maps (72.22 KB, text/plain)
2011-11-08 03:38 EST, Jan Kratochvil
no flags Details
File: backtrace (43.13 KB, text/plain)
2011-11-08 03:39 EST, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2011-11-08 03:38:45 EST
libreport version: 2.0.7
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --splash-pipe=7
comment:        Just ran libreoffice from commandline, opened several types of new documents (text+drawing+presentation etc.) and left it untouched running.  It crashed in several minutes.
crash_function: SalDisplay::addXineramaScreenUnique
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.0-7.fc16.x86_64
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Mon 07 Nov 2011 11:17:07 AM CET
uid:            1000
username:       lace

backtrace:      Text file, 44163 bytes
build_ids:      Text file, 6847 bytes
dso_list:       Text file, 18756 bytes
maps:           Text file, 73951 bytes

var_log_messages:
:Nov  7 11:17:07 host2 kernel: [148475.618158] soffice.bin[1849]: segfault at 0 ip 00007ff8e1e88755 sp 00007fff59ecbf40 error 6 in libvclplug_genlx.so[7ff8e1dde000+d6000]
:Nov  7 11:17:08 host2 abrt[2351]: saved core dump of pid 1849 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-11-07-11:17:07-1849 (98668544 bytes)
Comment 1 Jan Kratochvil 2011-11-08 03:38:50 EST
Created attachment 532236 [details]
File: dso_list
Comment 2 Jan Kratochvil 2011-11-08 03:38:52 EST
Created attachment 532237 [details]
File: build_ids
Comment 3 Jan Kratochvil 2011-11-08 03:38:58 EST
Created attachment 532238 [details]
File: maps
Comment 4 Jan Kratochvil 2011-11-08 03:39:03 EST
Created attachment 532239 [details]
File: backtrace
Comment 5 Caolan McNamara 2011-11-08 05:32:49 EST
This is in the method which is supposed to be triggered when monitors changed, e.g. new monitor plugged in or dimensions changed.
Comment 6 Caolan McNamara 2011-11-08 05:41:24 EST
Odd, SalDisplay::addXineramaScreenUnique with apparently an i of 0 and a crash in m_aXineramaScreenIndexMap[i] = m_aXineramaScreens.size();, which suggests that m_aXineramaScreenIndexMap is therefore of length 0, but we have...

m_aXineramaScreenIndexMap = std::vector<int>(nMonitors);
for (gint i = 0; i < nMonitors; ++i) 
{
    GdkRectangle dest;
    gdk_screen_get_monitor_geometry(pScreen, i, &dest);
    addXineramaScreenUnique( i, dest.x, dest.y, dest.width, dest.height );
}

so there isn't a way to get an empty m_aXineramaScreenIndexMap and then call addXineramaScreenUnique on it, it has to be non-empty.
Comment 7 Jan Kratochvil 2011-11-08 05:48:34 EST
I can confirm your monitor suspection.  It is reproducible for me if I turn off and turn on my external LCD.

This is X220 notebook with "Use this output" disabled for its "Laptop" output in XFCE and using the "HDMI1" output instead (X220 has DP connector).

Normal mode:

# xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1366x768       60.0 +
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      59.9*+   60.0     60.0  
   1680x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)


After turning off the "HDMI1" output:
# xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1366x768       60.0 +
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
  1920x1080 (0x4e)  138.5MHz
        h: width  1920 start 1968 end 2000 total 2080 skew    0 clock   66.6KHz
        v: height 1080 start 1083 end 1088 total 1111           clock   59.9Hz


There is in fact no active display that time.
Comment 8 Julian Stecklina 2011-11-09 11:46:43 EST
Package: libreoffice-core-3.4.3.2-15.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
1. Open a presentation in Libreoffice Impress
2. Change monitor layout (i.e., add an external monitor)
Comment 9 Caolan McNamara 2011-11-09 12:03:19 EST
Grrr, will figure out how this on-the-face-of-it-impossible condition comes to pass, just need to dig out some cables tomorrow.
Comment 10 Caolan McNamara 2011-11-10 06:08:27 EST
*sob*, there are *two* m_aXineramaScreenIndexMap, one of them shadowing the other, so one gets resized, and the one used remains at 0. Already fixed in 3-4 branch
Comment 11 Caolan McNamara 2011-11-10 06:19:19 EST
Will be good in >= 3.4.3.2-16 which I'm building now
Comment 12 Fedora Update System 2011-11-11 13:21:03 EST
libreoffice-3.4.4.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-1.fc16
Comment 13 igor.redhat@gmail.com 2011-11-11 14:18:27 EST
Package: libreoffice-core-3.4.3.2-15.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
This happened seemingly on its own when I wasn't using libre office. In case this is relevant, this happened shortly after resume (a couple of minutes after)...
Comment 14 Fedora Update System 2011-11-11 15:29:12 EST
libreoffice-3.4.4.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-2.fc16
Comment 15 Fedora Update System 2011-11-11 22:26:26 EST
Package libreoffice-3.4.4.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.4.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15789
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-11-15 19:30:53 EST
libreoffice-3.4.4.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 David Tardon 2011-11-21 02:19:13 EST
*** Bug 755389 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2011-11-23 10:40:29 EST
libreoffice-3.4.4.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-3.fc16

Note You need to log in before you can comment on or make changes to this bug.