Bug 75203 - Loopback mounting tip is not complete and is it in the right place?
Loopback mounting tip is not complete and is it in the right place?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
http://www.redhat.com/docs/manuals/li...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 09:38 EDT by Greg Morgan
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 11:05:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Morgan 2002-10-05 09:38:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I have a Samba server stuffed into the stereo cabinet.  I have two dual boot
me/rh7.3 client workstations that I want to install RH 8.0 on.  I would like to
use one of the network methods just because I have not tried this before.  The
samba server would hold the either the ISOs or an installation tree.  I have
used -o loop to modify iso images found in the leaf.sourceforge.net project
before.  However, I found the tip found on page 39 Section 3.10 Installing via
HTTP or
http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/install-guide/s1-begininstall-http.html
incomprehensible, "You can also install Red Hat Linux using ISO images without
copying them into a single tree by loopback mounting them as:

disc1/,disc2/,disc3/"

Note that this tip is repeated under section 3.9 Installing via FTP.
http://www.redhat.com/docs/manuals/linux/RHL-8.0-Manual/install-guide/s1-begininstall-ftp.html


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.man mount
2.search for loop via /loop
3.read information in the man page about the loop devices that I didn't know
4.search www.google.com using "-o loop" the most interesting link was
http://www.elis.rug.ac.be/~ronsse/cdfs/, but it did not describe the
disc1/,disc2/,disc3/ technique.  It showed how to mount three ISO images in
three mount points.
	

Actual Results:  I was unable to use this tip. 

Expected Results:  First off, should this tip have been placed under section
3.7.1 or 3.7.1.1?

I expected to see an example of how to do this.  "disc1/,disc2/,disc3/" sounds
like I can use one mount point to hold three ISO images in one mount operation?
 It also sounds like it would combine all tree ISO images into one install tree.
 Using -o loop is a novelty for many Linux users I know.  mount -t iso9660
myiso.iso /mnt -o loop is an unusual concept because there is no physical cd
involved. Are you saying that something like
http://www.ibiblio.org/pub/linux/distributions/redmondlinux/redmond/build38/rl/build-bin/mount-all-images
can be performed? This link was retrieved via the google search listed above.  

The tip needs to be embellished.   Would you please elaborate on how to do this,
or explain it in more detail here?
Comment 1 Miloslav Trmac 2002-10-05 17:00:40 EDT
no, you make three separate loopback mounts:
mkdir disc1 disc2 disc3
mount -o loop psyche-1.iso disc1
mount -o loop psyche-2.iso disc2
mount -o loop psyche-3.iso disc3

But I agree this should be clarified, expecially when the disc1/,disc2/,disc3/
is typeset as a command/computer output.
Comment 2 Sandra Moore 2002-12-16 11:05:30 EST
Thanks for the feedback. This tip for loopback mounting will be clarified for
the next release of Red Hat Linux.

Note You need to log in before you can comment on or make changes to this bug.