Bug 7521 - Upgrade quits (and reboots) after RPM database rebuild
Upgrade quits (and reboots) after RPM database rebuild
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-02 17:24 EST by Benjamin Kahn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 18:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 1999-12-02 17:24:14 EST
I burned the ISO image for Redhat 6.1 and upgraded 7 RHLinux 6.0 machines
without any problems.  When I got to my machine, things went differently.
While the dialog box (I used the graphical mode) saying Rebuilding RPM
database was on the screen, the computer rebooted with no helpful error
messages.  The dialog was on the screen long enough before the reboot that
it is hard to tell if the operation was completed.  However, trying to
install again would fail because the /mnt/sysimage/var/lib/rpmrebuild.22
existed.  I could delete this file and get the same weird reboot.

Actions tried:  Rebuilding the database myself first.  Upgrading to the RPM
on the cd and rebuilding first.  Using Text mode (this said: unexpectedly
exiting and rebooted.)  Using Expert Mode.  Using the updated installer
(This crashed during the sys/loader line.)

	What can I do?  What is wrong with this one machine?
Comment 1 Jay Turner 2000-02-22 13:29:59 EST
What installation method was this?  FTP? HTTP?  NFS?
Comment 2 Benjamin Kahn 2000-02-22 13:33:59 EST
As stated in the problem description, this was a CD ISO install.  So, it's
getting the data from the CD.
Comment 3 Jay Turner 2000-02-23 16:30:59 EST
I am not able to replicate this in the test lab, but the one thing that I am
thinking is this.  Did you download the ISO image and burn that, or did you
download the distribution and make a CDROM out of it.  Also, if you did download
the ISO, did you modify it in any way.  The only time that I have seen a crash
at this point in an upgrade is when the permissions on the CDROM are wrong.
Comment 4 Jay Turner 2000-02-24 09:41:59 EST
Another question is that.  Is /var a symbolic link on your system??  The
installer is not able to follow absolute symbolic links, so if you have either
/var or /tmp linked to somewhere else on the machine that you are having
problems with, this could be the cause of your problem.  Merely changing those
links to relative links will solve the problem.
Comment 5 Benjamin Kahn 2000-02-24 09:59:59 EST
Here are my steps again:

I logged into Redhat's FTP site and downloaded the ISO CD image.  I burned the
image and went around installing the CD on 7 different computers.  When I got to
my OWN computer, the upgrade died during the RPM database rebuild.  So this CD
had worked many times over, and continues to work on other machines.  On my
machine it does not.

Some clues: Rebuilding the database myself does not leave any errors.  The
temporary files for rebuilding the database are still there after the sudden
reboot.  It looks like the rebuild failed with a signal, and the installer just
quits out when that happens.

/var and /etc are /tmp are NOT symlinks.  In most other ways, this computer is
exactly the same as the others.  (Although I do more playing on this one.)

Would you suggest mounting the CD and trying to rebuild the database from the on
CD tools?

Note You need to log in before you can comment on or make changes to this bug.