Bug 75218 - Pgaccess is missing from distribution
Pgaccess is missing from distribution
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
David Lawrence
file:///usr/share/doc/postgresql-7.2....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 12:25 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 13:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-05 12:25:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The pgaccess application seems to be missing, and yes I did install the extra
postgresql- applications on disk 3 including mx.

rpm -qa | grep -i postgresql
postgresql-python-7.2.2-1
postgresql-devel-7.2.2-1
postgresql-7.2.2-1
postgresql-jdbc-7.2.2-1
postgresql-perl-7.2.2-1
postgresql-odbc-7.2.2-1
postgresql-libs-7.2.2-1
postgresql-contrib-7.2.2-1
postgresql-server-7.2.2-1
postgresql-tcl-7.2.2-1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Not really this kind of issue
2.
3.
	

Actual Results:  Not really this kind of issue

Expected Results:  Well, I would have expected it to be there and start.

Additional info:

AFAIK this is the only postgresql client provided. psql doesn't count either as
it is NOT  a user tool.
Comment 1 Dmitri Rasnitsyn 2002-10-26 11:13:02 EDT
The problem is caused by missing RPM.

postgresql-tk-7.2.2 is missing in 8.0. RedHat 7.3 has postgresql-tk RPM, so 
everything is fine there.

The workaround is to get the missing RPM from PostgreSQL web site (it's 
designated for RH7.3, but works fine with 8.0)
Comment 2 Need Real Name 2002-11-14 10:27:35 EST
Hi!

I propose a better workaround:
download the postgresql .src.rpm from the RH8.0 tree
install it: rpm -Uvh postgresql-7.2.2-1.src.rpm
go to /usr/src/redhat/SPECS
edit the file and replace
%{!?tkpkg:%define tkpkg 0} by 
%{!?tkpkg:%define tkpkg 1}

for the extra documentation:
%{!?sgmldocs:%define sgmldocs 0} by
%{!?sgmldocs:%define sgmldocs 1}

save the file and rebuild the packages:
rpmbuild -ba postgresql.spec

check in /usr/src/redhat/RPMS/i386

This should do the trick... This is what I am doing at the moment. I hope to get
the missing packages... :)

Daniel
Comment 3 Need Real Name 2002-11-14 11:14:20 EST
Hello again,

I forgot an important one...
from
%{!?pgaccess:%define pgaccess 0}
to
%{!?pgaccess:%define pgaccess 1}
...

Now we should be able to play with pg_access...
Comment 4 Andrew Overholt 2003-03-04 12:36:00 EST
Assigning to me.
Comment 5 Andrew Overholt 2003-04-14 13:36:46 EDT
We are not working on adding pgaccess back into the distribution at this time as
our current efforts are directed towards our own PostgreSQL Admin tool which can
be found at http://sources.redhat.com/rhdb/ .

Note You need to log in before you can comment on or make changes to this bug.