Bug 75236 - Tray icons stack (up and down) improperly when a gnome panel is configured for "small".
Tray icons stack (up and down) improperly when a gnome panel is configured fo...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 72370 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 15:36 EDT by Shane R. Stixrud
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 23:13:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image showing how the system tray stacks icons wrong (78.88 KB, image/png)
2002-10-26 10:35 EDT, Christian Schaller
no flags Details

  None (edit)
Description Shane R. Stixrud 2002-10-05 15:36:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I have configured a "menu panel" and placed an applet tray on this panel.  After
booting in to gnome the redhat applet appears fine.  After running an
application which requires root the authenication keys applet stacks on top of
the RedHat applet.  This result in both applets being only partly visable.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a menu panel
2.Place applet tray on this panel
3.Make sure rhn_applet and authenication keys applet is loaded
	

Actual Results: Applets stacks (up and down), making nither fully visable.

Expected Results:  Applets should stack left to right instead of up and down.
Additional info:
Comment 1 Havoc Pennington 2002-10-05 16:37:01 EDT
Possibly a side effect of the same breakage in
http://bugzilla.gnome.org/show_bug.cgi?id=94625
Comment 2 Christian Schaller 2002-10-26 10:35:10 EDT
Created attachment 82209 [details]
Image showing how the system tray stacks icons wrong
Comment 3 Christian Schaller 2002-10-26 10:36:52 EDT
Trouble seeing how this bug is related to that crasher bug in gnome bugzilla. I
just uploaded a screenshot showing this bug. I have two tray applets running
Gaim and Rhythmbox and instead of getting stacked horizontally in a horizontal
panel they get stacked vertically.
Comment 4 Havoc Pennington 2002-10-26 11:10:52 EDT
The crasher bug in bugzilla is because the applet tracks its orientation
incorrectly (it confuses PanelAppletOrient or whatever with GtkOrientation)
resulting in an assertion failure.

So I'm wondering if this bug is caused by the same, just the applet 
thinking it's vertical. If so this bug would be fixed in GNOME CVS.
Comment 5 Christian Schaller 2002-11-11 12:40:06 EST
Ok, I finally managed to get GNOME 2.1.x running and correctly enough this bug
is gone in that version. As a sidenote the 'handle' is larger and due to that
less visualy pleasing in this version.
Comment 6 Havoc Pennington 2002-12-21 15:31:21 EST
*** Bug 72370 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2003-01-07 23:13:56 EST
OK, should be fixed in rawhide.
Comment 8 Havoc Pennington 2003-07-02 18:51:25 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-219.html

Note You need to log in before you can comment on or make changes to this bug.