Bug 752402 - os-prober doesn't find linux OS on mdraid partitions
os-prober doesn't find linux OS on mdraid partitions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: os-prober (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Hedayat Vatankhah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 07:21 EST by Pavel Lisý
Modified: 2012-06-10 20:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 19:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working script (4.23 KB, application/octet-stream)
2011-11-09 07:22 EST, Pavel Lisý
no flags Details
new version of patch (875 bytes, patch)
2011-11-09 13:38 EST, Pavel Lisý
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 648251 None None None Never

  None (edit)
Description Pavel Lisý 2011-11-09 07:21:26 EST
Description of problem:
When I have another linux distribution on /dev/md* os-prober finds nothing

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install f15 on /dev/md3
2. run os-prober on f16
3. it returns nothing
  
Actual results:
returns nothing

Expected results:
# os-prober 
/dev/md3:Fedora release 15 (Lovelock):Fedora:linux


Additional info:
This bug breaks grub2-mkconfig too

I sending new script and patch which solves it.
Comment 1 Pavel Lisý 2011-11-09 07:22:05 EST
Created attachment 532552 [details]
working script
Comment 2 Hedayat Vatankhah 2011-11-09 08:40:09 EST
Thank you for reporting the issue and for the fix. Unfortunately, I don't have any software raid devices. Apparently, md raid devices were excluded due to this bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=273960%3b
Would you please check to see if your patch actually fixes this bug? If yes, I would forward this patch upstream to be included in the next version.
Comment 3 Pavel Lisý 2011-11-09 13:37:08 EST
I've made new patch which adds only /dev/md* devices and excludes /dev/sda* (and so on) which are parts of md raid devices. I think you can send it to upstream.
Comment 4 Pavel Lisý 2011-11-09 13:38:16 EST
Created attachment 532641 [details]
new version of patch
Comment 5 Fedora Update System 2012-05-25 08:53:45 EDT
os-prober-1.53-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/os-prober-1.53-2.fc16
Comment 6 Fedora Update System 2012-05-25 08:54:01 EDT
os-prober-1.53-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/os-prober-1.53-2.fc17
Comment 7 Fedora Update System 2012-05-26 04:07:03 EDT
Package os-prober-1.53-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing os-prober-1.53-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8433/os-prober-1.53-2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-02 12:54:12 EDT
os-prober-1.53-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/os-prober-1.53-3.fc16
Comment 9 Fedora Update System 2012-06-02 12:55:39 EDT
os-prober-1.53-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/os-prober-1.53-3.fc17
Comment 10 Fedora Update System 2012-06-02 19:56:32 EDT
os-prober-1.53-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-06-08 20:03:07 EDT
os-prober-1.53-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-06-10 20:00:00 EDT
os-prober-1.53-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.