Bug 75242 - Installer does not handle LVM/SMB filesystems in /etc/fstab during upgrade
Installer does not handle LVM/SMB filesystems in /etc/fstab during upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 17:27 EDT by Frode Tennebø
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frode Tennebø 2002-10-05 17:27:26 EDT
Description of Problem:

If /etc/fstab contains LVM and/or SMB filesystems when upgrading fra 7.3 to 
8.0 the installer reports something to the wording of "Your systesm 
/etc/fstab contains filesystems which cannot be mounted properly. Please 
reboot and fix the problem."

I'm not sure if this applies to both the filesystem residing on LVM and the 
one with SMBFS, but I commented out those entries and I managed to upgrade.

Steps to Reproduce:
1. Have a RH 7.3 installation with something like this in the /etc/fstab


//luke/C                /mnt/luke/C             
smbfsrw,uid=ft,gid=ftgr,username=ft,password=xxxx 0 0
#/dev/vg1/opt           /opt                    ext2    defaults        1 5

2. 
3. 

Actual Results:


Expected Results:


Additional Information:

This has been like this at least the three last uprades I have done and is 
really anoying since the installer is actually rebooting. A nice thing 
would be to just let me know, let med fix it and tries again. An even nicer 
thing would be just to ignore it since the filesystems in question did not 
containg any files relevant to the upgrade.
Comment 1 Frode Tennebø 2002-10-05 17:29:06 EDT
Argh.....

Steps to Reproduce:
1. Have a RH 7.3 installation with something like this in the /etc/fstab

//luke/C                /mnt/luke/C            smbfs 
rw,uid=ft,gid=ftgr,username=ft,password=xxxx 0 0
/dev/vg1/opt           /opt                    ext2    defaults        1 5

2. Upgrade to RH 8.0
3. Voila
Comment 2 Jeremy Katz 2002-10-07 16:44:12 EDT
I'm guessing this is due to the SMB filesystem and not the logical volume.  I'll
try to test that shortly
Comment 3 Jeremy Katz 2002-10-25 16:06:22 EDT
I can't reproduce this at all here -- can you try commenting out one at a time
to verify that it's one or the other?
Comment 4 Frode Tennebø 2002-10-26 17:55:14 EDT
I tried upgrading again and reproduced the problem. Having the SMB filesystem 
in the fstab works fine. It's the LVM which causes trouble.

The exact warning is "One or more of the file systems listed in the /etc/fstab 
on your Linux system cannot be mounted. Please fix this problem and try to 
upgrade again."

This happens right after I select "select indivdual packages" (or something 
like that).
Comment 5 Jeremy Katz 2002-10-31 18:23:53 EST
Are there any messages on tty3 or tty4 about the volume group?
Comment 6 Frode Tennebø 2002-11-01 17:41:36 EST
There's plenty of messages.. :)

LVM version 1.0.3(19/02/2002) module loaded
:
:
kjounrlad starting: Commit intervals 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide0(3,2)
EXT3-fs: mounted filesystem with ordered data mode

The three messages are repeated for:
ide0(3,65), ide1(22,1), sd(8,11), ide0(3,65).

Before pressing "next" on "select indivdual packages" I did a:

> mount /dev/vg1/opt /opt
mount: Mounting /dev/vg1/opt on /opt failed: No such device or address

However, doing a:
> vgchange -a y
> mount /dev/vg1/opt /opt

resulted in a successfull mount.
Comment 7 Jeremy Katz 2003-01-03 00:28:26 EST
There were some bugs with LVM-related upgrade cases that are fixed in our newer
code base, which is probably why I can't reproduce it now.
Comment 8 Frode Tennebø 2003-04-08 10:53:25 EDT
This is still a problem with RH9. I upgraded from RH8.0 wih LVM in /opt (as above). This resulted in a very similar error as above. Commenting out the LVM fs from /etc/fstab is a workaround.

At least is should be possible to back and try again when experiencing this error. This way the user can edit /etc/fstab without having to reboot first.
Comment 9 Mark W. Jeanmougin 2003-05-31 14:14:31 EDT
I'm having this problem when upgrade to Shrike / RH9.

I stripped all LVM related things from my /etc/fstab and it seemd like it was
working (other than the fact that /usr and /var are on LVM).  So, once I added
/var and /usr to /etc/fstab, I get the error message about "One or more of the
file systems listed in the /etc/fstab on your Linux system cannot be mounted. 
Please fix this problem and try to upgrade again."

The frustrating parts are:
- It doesn't tell me which ones can't be mounted.  Please list which filesystems
couldn't be mounted to make troubleshooting easier.  This seems like a
reasonable request.
- If I go to another virtual terminal, then I can mount filesystems just fine. 
What's up?

Please help,

MJ
Comment 10 Jeremy Katz 2004-10-04 22:50:53 EDT
This should be better in newer releases

Note You need to log in before you can comment on or make changes to this bug.