Bug 75248 - up2date, config-printer, etc can't open iconv module
up2date, config-printer, etc can't open iconv module
Status: CLOSED DUPLICATE of bug 76104
Product: Red Hat Linux
Classification: Retired
Component: rhpl (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 20:15 EDT by Nathan Bryant
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 22:25:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Bryant 2002-10-05 20:15:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
up2date and redhat-config-printer both fail with the following on a system
upgraded to redhat 8.0. the system formerly had RH 7.3 and before that, Skipjack
and 6.2 and probably others.

I don't remember how the upgrade from Skipjack to 7.3 was accomplished, but the
machine had been working fine subsequently...

[root@spaceheater RPMS]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 18, in ?
    from up2date_client import up2dateMessages
  File "/usr/share/rhn/up2date_client/up2dateMessages.py", line 12, in ?
    from rhpl.translate import _, N_
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 197, in ?
    cat = i18n()
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 75, in __init__
    self.setDomain(domain)
  File "/usr/lib/python2.2/site-packages/rhpl/translate.py", line 134, in setDomain
    self.iconv = iconv.open(self.codeset, encoding)
ValueError: (22, 'Invalid argument')


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. just run up2date on this machine.
2.
3.
	

Additional info:
Comment 1 Jeremy Katz 2002-10-07 11:51:30 EDT
What is the output of the locale command?
Comment 2 Nathan Bryant 2002-10-10 22:25:00 EDT
[nathan@spaceheater nathan]$ locale
LANG=POSIX
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
[nathan@spaceheater nathan]$
Comment 3 Nathan Bryant 2002-12-03 13:00:07 EST

*** This bug has been marked as a duplicate of 76104 ***

Note You need to log in before you can comment on or make changes to this bug.