Bug 75261 - German output is incomplete
German output is incomplete
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-switchmail (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 05:38 EDT by Thorsten Leemhuis
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 06:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2002-10-06 05:38:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
After changing MTA on a german RH 8.0 a dialog pops up with the incomplete
sentence "Ihre MTA Konfiguration wurde erfolgreich aktualisiert, Sie m"
There it stops

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Change Locale to german
2.Start redhat-switchmail
3.Klick Okay
	

Actual Results:  See desciption

Expected Results:  A complete sentence?

Additional info:

[thl@work thl]$ cat /etc/sysconfig/i18n
LANG="de_DE.UTF-8"
SUPPORTED="de_DE.UTF-8:de_DE:de"
SYSFONT="latarcyrheb-sun16"
Comment 1 Ngo Than 2002-10-06 06:36:01 EDT
It's perhaps a bug in po file.
Comment 2 Miloslav Trmac 2002-10-06 08:30:40 EDT
The trouble is that redhat-switchmail doesn't like when the .po
files are not in UTF-8. While gettext () does transparent charset
conversion, something in redhat-switchmail doesn't.

Looking at i18n CVS, this will probably affect at least the following languages:
da, de, es fr, is, it, ru; not sure about ja.
It also affects cs, which is already fixed in CVS.

This problem occurrs also in apacheconf, bindconf, hwbrowser,
redhat-config-services and up2date (though the affected language sets differ).
I will file bugs for these packages shortly.

The workaround is to recode the file to UTF-8, i. e.
cd /usr/share/locale/XX/LC_MESSAGES
msgunfmt redhat-switchmail.mo -o x
fgrep Content-Type x         [see charset]
iconv -f charset_from_above -t utf-8 < x > x2
msgfmt x2 -o redhat-switchmail.mo
Comment 3 Miloslav Trmac 2002-10-06 08:34:31 EDT
Oh, I forgot: the symptoms include message
** (redhat-switchmail:1220): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

when redhat-switchmail is run from a terminal.
Comment 4 Miloslav Trmac 2002-10-06 08:41:02 EDT
I'm terribly sorry; in the workaround, replace the iconv line with
msgconv -t utf-8 x -o x2
Comment 5 Miloslav Trmac 2002-10-06 10:04:20 EDT
Other packages seem no to be affected, all but up2date (and redhat-switchmail)
do automatic recoding to UTF-8 before compiling the catalogs.
Comment 6 Ngo Than 2003-08-12 06:24:06 EDT
the problem is that the po files are not saved in utf-8. It's fixed now in
redhat-switch-mail-0.5.19-1 or newer, which is available in rawhide

Note You need to log in before you can comment on or make changes to this bug.