Bug 752620 - Override install paths for OS X (Darwin) + Macports install
Override install paths for OS X (Darwin) + Macports install
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Misty Stanley-Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 19:50 EST by Misty Stanley-Jones
Modified: 2014-06-18 03:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2011-11-09 19:50:37 EST
To install Publican on OS X with Macports, set the following install_path parameters:

sudo ./Build install --install_path datadir=/opt/local/share/publican --install_path generated=/opt/local/share/publican/sitetemplate  --install_path web=/opt/local/share/publican/sitetemplate --install_path templates=/opt/local/share/publican/templates --install_path etc=/opt/local/etc --install_path completion=/opt/local/etc/bash_completion.d

Publican also needs to override the common_config and common_content paths like this:

publican create --name=testbook --common_config=/opt/local/share/publican --common_content=/opt/local/share/publican/Common_Content

Perl information:

misty:~ misty$ perl -e 'print $^O, "\n"'
darwin

The Perl installed by default in OS X is at /usr/bin/perl and reports the same architecture:
misty:~ misty$ /usr/bin/perl -e 'print $^O, "\n"'
darwin

It might be worth checking the path for perl, and only overriding the paths if Perl is installed in /opt/local/bin. Both binaries present as exactly the same version. If you were using /usr/bin/perl you'd probably want to install Publican into its standard paths.
Comment 1 Jeff Fearn 2011-11-09 22:18:40 EST
Hi, I have put the code for this in place, however I can't test it has the desired effect on darwin ... since I don't have it :)

Changed default install paths on darwin:

from '/usr/share/publican' to '/opt/local/share/publican'
from '/etc' to '/opt/local/etc'
from '/etc/bash_completion.d' to '/opt/local/etc/bash_completion.d'

Changed default path for common_config from '/usr/share/publican'  to '/opt/local/share/publican'

Changed default path for common_content from '/usr/share/publican/Common_Content'  to '/opt/local/share/publican/Common_Content'

Applied changes to branches/publican-2x and trunk.

Committed revision 1939.
Comment 2 Michael Hideo 2012-06-07 21:49:08 EDT
only misty can do this. sorry misty.
Comment 3 Misty Stanley-Jones 2012-06-08 05:55:01 EDT
Verified in the real world two weeks ago.

Note You need to log in before you can comment on or make changes to this bug.