Bug 75266 - traceback ipcalc.py:network:60
traceback ipcalc.py:network:60
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 105862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 10:00 EDT by Ted Kaczmarek
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 07:21:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2002-10-06 10:00:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Neat crashes when disabling eth0(dhcp) and adding default route to eth1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 8.0 with eth0 setup for dhcp, eth1 private lan, eth0 timeout on boot.
2.Run neat
3.Disable activation of eth0 on boot, add default gateway to eth1
	

Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

Expected Results:  Application finishes, eth0 disabled on activation and default
route added. On second crash it actually disables thge interface and adds the
route, but same scnario repeats.

Additional info:

Install was done with eth0 setup for dhcp, eth1 private lan. For testing 
I only am using eth1, eth0 timesout on boot. If I use neat to disable activation
of eth0 on boot and add default route on eth1 it crashes every time.

destination 0.0.0.0
metmask     0.0.0.0
gateway     "inside firewall int"
Comment 1 Ted Kaczmarek 2002-10-06 10:10:04 EDT
Terminal launch errors, this time I just tried to enable eth0.
[root@nitremb21 sysconfig]# neat

** (neat:1475): WARNING **: could not find handler `on_cancelButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_deviceNameEntry_insert_te
xt'

** (neat:1475): WARNING **: could not find handler `on_okButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_deviceNameEntry_changed'

** (neat:1475): WARNING **: could not find handler `on_routeAddButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_routeDeleteButton_clicked
'

** (neat:1475): WARNING **: could not find handler `on_routeEditButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_hardwareAliasesToggle_tog
gled'

** (neat:1475): WARNING **: could not find handler `on_hardwareProbeButton_click
ed'

** (neat:1475): WARNING **: could not find handler `on_hardwareMACToggle_toggled
'

** (neat:1475): WARNING **: could not find handler `on_hardwareAliasesToggle_tog
gled'

** (neat:1475): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:1475): WARNING **: could not find handler `on_ipAutomaticRadio_toggled'

** (neat:1475): WARNING **: could not find handler `on_hardwareProbeButton_click
ed'

** (neat:1475): WARNING **: could not find handler `on_hardwareMACToggle_toggled
'

** (neat:1475): WARNING **: could not find handler `on_routeAddButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_routeDeleteButton_clicked
'

** (neat:1475): WARNING **: could not find handler `on_routeEditButton_clicked'

** (neat:1475): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:1475): WARNING **: could not find handler `on_ipAutomaticRadio_toggled'
ipraceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'calc: bad prefix: 0





Comment 2 Greg Shaw 2002-11-20 15:06:15 EST
Similar traceback. Same line number. Different actions to get to fault.

Description:
neat crashes when Applying changes to names of some machines and adding new
machine. Repeatable when doing either on their own.

System:
eth1: ethernet (10/100)
eth0: wireless (USB using atmelwlandriver)
redhat-config-network: 1.1.20-1

Steps to reproduce:
1. start neat.
2. Goto Hosts tab and Edit existing machine.
3. Change name and click OK.
4. Click Close to apply changes. Produces attached traceback.

shell reports:
 ipcalc: bad prefix: 0

Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'
Comment 3 Ted Kaczmarek 2002-12-22 13:56:23 EST
In this setup eth0 is dhcp always works ok, eth1 is static, will crash
occasionally, but not easy to reproduce when adding statis routes.
Making almost any change  to cipcb0 or cipcb1 will cause it to crash.
On 7.3 boxes 

[root@nitremb21 cipe]# neat
Copying ifcfg-cipcb1 to devices and putting it into the default profile.
Copying ifcfg-cipcb0 to devices and putting it into the default profile.

** (neat:15721): WARNING **: could not find handler `on_remotePeerAddressCB_toggled'

** (neat:15721): WARNING **: could not find handler `on_ethernetDeviceEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_cipeDeviceEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remoteVirtualAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_secretKeyEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_generateKeyButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_localPortEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remotePeerAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remotePeerAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_localVirtualAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_cancelButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_deviceNameEntry_insert_text'

** (neat:15721): WARNING **: could not find handler `on_okButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_deviceNameEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_hardwareAliasesToggle_toggled'

** (neat:15721): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:15721): WARNING **: could not find handler `on_ipAutomaticRadio_toggled'

** (neat:15721): WARNING **: could not find handler `on_hardwareProbeButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_hardwareMACToggle_toggled'

** (neat:15721): WARNING **: could not find handler `on_remotePeerAddressCB_toggled'

** (neat:15721): WARNING **: could not find handler `on_ethernetDeviceEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_cipeDeviceEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remoteVirtualAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_secretKeyEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_generateKeyButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_localPortEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remotePeerAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_remotePeerAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_localVirtualAddressEntry_changed'

** (neat:15721): WARNING **: could not find handler `on_cancelButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_deviceNameEntry_insert_text'

** (neat:15721): WARNING **: could not find handler `on_okButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_deviceNameEntry_changed'

** (neat:15721): WARNING **: could not find handler
`on_hardwareAliasesToggle_toggled'

** (neat:15721): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:15721): WARNING **: could not find handler `on_ipAutomaticRadio_toggled'

** (neat:15721): WARNING **: could not find handler `on_hardwareProbeButton_clicked'

** (neat:15721): WARNING **: could not find handler `on_hardwareMACToggle_toggled'
ipcalc: bad prefix: 0
Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 60,
in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

> /usr/share/redhat-config-network/netconfpkg/ipcalc.py(60)network()
-> return re.match("NETWORK=(\S+)", text).groups()[0]
(Pdb) 

Comment 4 Harald Hoyer 2004-09-21 08:10:19 EDT
*** Bug 105862 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.