Bug 75289 - Assertion failure in journal_commit_transaction() - PERC raid
Assertion failure in journal_commit_transaction() - PERC raid
Status: CLOSED DUPLICATE of bug 66247
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 17:49 EDT by R P Herrold
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 03:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-10-06 17:49:47 EDT
I queried Bugzilla and do not see this reported:

kernel panic - server3
----- Message Text -----

Assertion failure in journal_commit_transaction() at
commit.c:535: "buffer_jdirty(bh)"
------------[ cut here ]------------
kernel BUG at commit.c:535!
invalid operand: 0000
binfmt_misc autofs eepro100 usb-ohci usbcore ext3 jbd aacraid
aic7xxx sd_mod s
CPU:    0
EIP:    0010:[<f88630e4>]    Not tainted
EFLAGS: 00010286


EIP is at journal_commit_transaction [jbd] 0xb04 (2.4.18-3smp)
eax: 0000001c   ebx: 0000000a   ecx: c02eee60   edx: 000039c6
esi: f66034c0   edi: f6815b00   ebp: f6c00000   esp: f6c01e78
ds: 0018   es: 0018   ss: 0018
Process kjournald (pid: 206, stackpage=f6c01000)
Stack: f8869eee 00000217 f77ed86c 00000000 00000fcc cfc79034
00000000 d012f640
       deaebf70 00000da4 f77ed800 00000000 f7dc4a00 f7824000
f6222980 cbc4cf20
       d84772a0 e286d6e0 f60ecf60 e1e615c0 f60f6ea0 e8a9b860
e5627f20 f609a6c0
Call Trace: [<f8869eee>] .rodata.str1.1 [jbd] 0x26e
[<c0124eb5>] update_process_times [kernel] 0x25
[<c0116049>] smp_apic_timer_interrupt [kernel] 0xa9

[<c010758d>] __switch_to [kernel] 0x3d
[<c0119048>] schedule [kernel] 0x348
[<f88657d6>] kjournald [jbd] 0x136
[<f8865680>] commit_timeout [jbd] 0x0
[<c0107286>] kernel_thread [kernel] 0x26
[<f88656a0>] kjournald [jbd] 0x0


Code: 0f 0b 5a 59 6a 04 8b 44 24 18 50 56 e8 4b f1 ff ff 8d 47
48

[herrold@server3 herrold]$


[herrold@server3 herrold]$ uname -a ; rpm -q kernel ; rpm -q
--qf '%{arch}\n' kernel
Linux server3.brook.tel 2.4.18-3smp #1 SMP Thu Apr 18 07:27:31
    EDT 2002 i686 unknown
kernel-2.4.18-3
i686


=======================

let me know if you need more information; we are running hardware (Dell PERC)
RAID on this unit, and had a drive (seemingly) die about a month ago, on this
same box.


SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec 3960D Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec 3960D Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel B, SCSI Id=7, 32/253 SCBs

scsi2 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.5
        <Adaptec aic7899 Ultra160 SCSI adapter>
        aic7899: Ultra160 Wide Channel B, SCSI Id=7, 32/253 SCBs

Red Hat/Adaptec aacraid driver, Apr 18 2002
scsi3 : percraid
  Vendor: DELL      Model: PERCRAID RAID5    Rev: 0001
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
SCSI device sda: 71089152 512-byte hdwr sectors (36398 MB)
sda: Write Protect is off
Partition check:
 sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 sda12 sda13 sda14 >
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
Comment 1 Stephen Tweedie 2002-10-07 04:28:59 EDT

*** This bug has been marked as a duplicate of 66247 ***

Note You need to log in before you can comment on or make changes to this bug.