This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 753127 - rebase to 1.0.8 request
rebase to 1.0.8 request
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-webob (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Malcolm
Desktop QE
: Rebase
Depends On:
Blocks: 782252
  Show dependency treegraph
 
Reported: 2011-11-11 07:05 EST by Pádraig Brady
Modified: 2016-01-04 09:47 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 12:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2011-11-11 07:05:30 EST
This is specifically to support openstack-glance
which has been tested mostly with 1.0.8

Also 1.0.8 would sync up with what was in Fedora 15 & 16
As an aside, 1.0.8 is required by TurboGears 2.1.1
Comment 2 Pádraig Brady 2011-11-11 07:13:58 EST
I'm suggesting this for rhel-6.3
bugzilla is complaining to me at the moment,
so I'll try later to set

rhel-6.3 ?
devel-ack ?
pm-ack ?
qa-ack ?
Comment 3 RHEL Product and Program Management 2011-11-11 07:28:50 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Jonathan Steffan 2011-11-16 18:19:55 EST
This is also needed for an update of openstack-swift to 1.4.3. I was about to request a branch in EPEL, so please get this done.
Comment 5 Pádraig Brady 2011-11-18 06:36:57 EST
I think it would be good for the rebased package to Provide: python-webob1.0
so that dependent packages can require just that, and thus not need to install the actual python-webob1.0 compat package too
Comment 6 Mark McLoughlin 2011-11-18 08:02:12 EST
(In reply to comment #5)
> I think it would be good for the rebased package to Provide: python-webob1.0
> so that dependent packages can require just that, and thus not need to install
> the actual python-webob1.0 compat package too

It may actually need a Conflicts: python-webob1.0 too, right? Because there would be file conflicts between the eggs in each package
Comment 7 Pádraig Brady 2011-11-18 08:44:20 EST
Good point. These would conflict for example if at the same version:

# rpm -qal "python-webob*" | grep PKG-INFO
/usr/lib/python2.6/site-packages/WebOb-0.9.6.1-py2.6.egg-info/PKG-INFO
/usr/lib/python2.6/site-packages/WebOb-1.0.8-py2.6.egg/EGG-INFO/PKG-INFO
Comment 15 Suzanne Yeghiayan 2012-01-31 16:19:18 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.

Note You need to log in before you can comment on or make changes to this bug.