Bug 753155 - RFE: implement logging to spice-xpi
RFE: implement logging to spice-xpi
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: beta
: 6.3
Assigned To: Peter Hatina
Desktop QE
: FutureFeature, Improvement
Depends On:
Blocks: 756082
  Show dependency treegraph
 
Reported: 2011-11-11 08:23 EST by David Jaša
Modified: 2017-02-07 07:43 EST (History)
12 users (show)

See Also:
Fixed In Version: spice-xpi-2.7-5.el6
Doc Type: Enhancement
Doc Text:
Some logging messages were added to spice-xpi, including spice-xpi functions called from the web page (javascript) and command line of processes that spice-xpi runs (e.g. spice-xpi-client)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice-xpi add logging messages patch (10.68 KB, patch)
2012-06-03 09:18 EDT, Uri Lublin
no flags Details | Diff

  None (edit)
Description David Jaša 2011-11-11 08:23:51 EST
Description of problem:
SSIA. Current spice-xpi code contains only logging definitions in spice-xpi/SpiceXPI/src/plugin/debug.h lines 90-116, but it is used nowhere else and spice-xpi log is always empty.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Cameron Meadors 2011-11-16 11:43:16 EST
Can't debug bug 752111 without spice-xpi logging.
Comment 3 David Jaša 2011-11-16 11:50:39 EST
(In reply to comment #1)
> Can't debug bug 752111 without spice-xpi logging.

I found out that some logging can be enabled in /usr/share/spice/logger.ini by raising log level to DEBUG, R:

log4j.rootCategory=DEBUG, R

But it doesn't help with our Guest Hot Name issue though. :(
Comment 4 David Jaša 2011-11-16 19:03:35 EST
Peter, at the moment, we basically need logging of two kind of things:

1) whenever a web page calls spice-xpi function, log it including all variables that are passed to spice-xpi

2) when spice-xpi runs any other process (spicec, usbrdrctrl), log it including full command line

Both of these should be in INFO level.

It would be also great if the traffic on the controller could be logged, preferably full messages in DEBUG level. But this is of lower priority, if you don't have enough time, just clone it to some other bug so we have the two points above ASAP.
Comment 5 Itamar Heim 2011-11-20 06:20:33 EST
please make sure the Spice ActiveX gets the same level of logging
Comment 9 David Blechter 2011-12-15 13:07:22 EST
devel acked. considering 6.3 and not 6.2.z due to the time and resources limitationsl
Comment 11 Peter Hatina 2012-02-14 08:03:07 EST
Fixed.
Comment 14 Bill Sanford 2012-03-12 14:54:50 EDT
Fixed in spice-xpi-2.7-13.el6.x86_64.
Comment 15 Uri Lublin 2012-06-03 07:57:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Some logging messages were added to spice-xpi, including spice-xpi functions called from the web page (javascript) and command line of processes that spice-xpi runs (e.g. spice-xpi-client)
Comment 16 Uri Lublin 2012-06-03 09:18:28 EDT
Created attachment 588854 [details]
spice-xpi add logging messages patch
Comment 18 errata-xmlrpc 2012-06-20 10:48:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0956.html

Note You need to log in before you can comment on or make changes to this bug.