Bug 75316 - lInstaller chooses incomplete console font for european countries
lInstaller chooses incomplete console font for european countries
Status: CLOSED DUPLICATE of bug 127265
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 04:38 EDT by Nicolas Mailhot
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2002-10-07 04:38:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When I choose an install using fr-latin0, the installer decides to use
latarcyheb-sun16 as console font.

This console font does not include the euro symbo, yet I've explicitely
requested euro support by choosing latin0 support.

While I'm grateful for the cyrillic support, I couldn't care less about the
hebrew one and anyway correct latin9 support is more important.

RH has been shipping euro console fonts (latin9*) for a few versions, but
curiously never bothered to use them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Type euro

Actual Results:  see garbage

Expected Results:  �

Additional info:

Please ship a euro-compliant distro, it's not as if it were a new problem anymore
Comment 1 Jeremy Katz 2002-10-07 17:03:10 EDT
The font is chosen as the one with the "best" coverage for a unicode console,
which is required now that we are using a unicode locale.  Reassigning to kbd
since that's where the font is.
Comment 2 Nicolas Mailhot 2002-10-08 03:50:21 EDT
Well, there are perfectly complete latin9 fonts shipped with redhat, in a sane
world it should be possible to build a paneuropean font by aggregating these
fonts with others.

I suppose the wrong one was chosen because of the unholy latin0 mess Red Hat got
itself in a few years ago.
Comment 3 Carlos Rodrigues 2002-10-08 10:47:12 EDT
I also can't use the euro symbol, not even after getting rid of the whole 
unicode thing. It worked fine in 7.3. I can't get away of the feeling that if 
it isn't broken don't fix it.
Comment 4 Eido Inoue 2004-02-26 20:31:59 EST
there's only so many characters that we can support in text mode at
one time. the alternative is to change your default to a font that
supports the euro (or the character you need), or to use a GUI if you
need a wider character range support.
Comment 5 Nicolas Mailhot 2004-02-27 03:54:39 EST
Excuse me but I do believe the euro zone have enough people inside it
fo the euro character to be mandatory inside the default font;)
Comment 6 Eido Inoue 2004-02-27 17:41:44 EST
after double-checking this bug (with showcfont from console-tools as
well as psfgettable to see the Unicode mappings).

I discovered that our default font DOES have the Euro character as
position 0x0AD. However, according to psfgettable, the character seems
to be incorrectly mapped to U+00AD U+2010 U+2011 and U+2013 (It's 0xA4
in Latin-9 aka ISO-8859-15, and U+20AC in Unicode)
Comment 7 Eido Inoue 2004-08-10 19:14:17 EDT

*** This bug has been marked as a duplicate of 127265 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:49:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.