Bug 75321 - Processing of <xml/> tag
Processing of <xml/> tag
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: psgml (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 05:22 EDT by Nicolas Mailhot
Modified: 2007-07-24 10:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2002-10-07 05:22:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
While psgml is awesome for sgml tags, its interest is severily limited for sgml
docs since it can't grok self-ending tags (<tag/> instead <tag></tag>).

These tags are both legitimate, necessary and common in xml since they help
reducing code bloat.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

Example 1 : 

Type some imbricated tags, both in the compact form and expanded one, and watch
as <tab> indents tags after a compact one one level further (ie. psgml didn't
realize the compact tag is already closed)

Example 2 :

Try to validate the document. Psgml complains of missing end tags for all
compact tags.
	

Additional info:

This is becomming more serious as xml usage expands and psqml remains the
prefered xml-editing solution under emacs.
Comment 1 Tim Waugh 2002-10-07 10:11:35 EDT
Are you using 'xml-mode' or 'sgml-mode'?  Indentation for XML files works fine 
for me. 
 
As for validation, it probably should use the command 'xmllint >/dev/null 
--loaddtd --valid' instead of nsgmls when in xml-mode.
Comment 2 Nicolas Mailhot 2002-10-07 10:36:36 EDT
Ok, I've checked another time, when I explicitely load xml-mode it works, when I
don't no luck.

So it seems the problem is RH 8.0 emacs will load psgml mode by default for xml
files (unless I redefined xml files default mode in my .emacs, but that does not
seem to be the case do you want my .emacs to check it ?)

(btw thanks for the validation tip)
Comment 3 Tim Waugh 2002-10-13 16:29:47 EDT
I think I saw a patch float past psgml-devel that fixes this, although with an 
nsgmls command line still (by supplying 'xml.dcl' first).
Comment 4 Bill Nottingham 2006-08-07 15:56:14 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 13:15:09 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.