Bug 75325 - misleading error message about newly-created root partition
misleading error message about newly-created root partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 05:59 EDT by Adam Spiers
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-28 13:38:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart config (1.41 KB, text/plain)
2002-10-15 13:46 EDT, Adam Spiers
no flags Details
Output of df run on tty2 after bogus anaconda error occurred (408 bytes, text/plain)
2002-10-28 12:56 EST, Adam Spiers
no flags Details
Output of mount run on tty2 after bogus anaconda error occurred (474 bytes, text/plain)
2002-10-28 12:57 EST, Adam Spiers
no flags Details

  None (edit)
Description Adam Spiers 2002-10-07 05:59:41 EDT
anaconda fails to mount a newly-created root partition,
and so attempts to install the OS onto the RAM disk,
causing an error about there not being enough disk space
to proceed with the install.

How Reproducible:
With a ks.cfg containing:

part /  --fstype ext3 --size 9000 --grow

anaconda successfully creates the new / partition,
but then complains it isn't big enough.  This is
probably because the ext3.o kernel module is missing
from the relevant boot image (in this case, 
redhat/linux/8.0/en/os/i386/images/pxeboot/initrd.img)

Please note that the correct fix for this is not
just to add ext3.o to the image, but also to add
a check for mount failure to anaconda, so that if
the mount of the new / partition fails, the error
message says this rather than the misleading report
that the partition was too small.
Comment 1 Jeremy Katz 2002-10-07 17:05:48 EDT
The ext3 module doesn't have to be on the first stage; it is in the second stage
moduleball.  Could you check if the ext3 module gets loaded then and if not,
what errors are given on tty3.  Also, could you attach your complete ks.cfg?
Comment 2 Adam Spiers 2002-10-15 13:44:22 EDT
What do you mean by the first stage and second stage module ball
exactly?  I was under the impression that the first kernel modules
the install sees are in pxeboot/initrd.img, and no more are 
encountered before the partitioning happens, hence the need for
ext3.o to be in this initrd.img.  I don't remember seeing any attempts
to insmod ext3.o on tty3 at the time, although it's possible that
the attempt could have just scrolled past, since the kernel loses
all scrollback every time you switch ttys.  I should be able to verify
this tomorrow.

If I added ext3.o to modules.cgz within pxeboot/initrd.img, wouldn't
this fix the problem?

[ks.cfg to be attached shortly]
Comment 3 Adam Spiers 2002-10-15 13:46:48 EDT
Created attachment 80524 [details]
kickstart config
Comment 4 Adam Spiers 2002-10-24 16:44:58 EDT
Bit puzzled why this has been changed to NEEDINFO.
Do you need any more info from me?
Comment 5 Adam Spiers 2002-10-28 12:26:00 EST
It appears that you were right, and this problem is more complex
than I first thought.  The same problem has just cropped up
with another ks.cfg.

Using the root shell on tty2 reveals that it *has* successfully
mounted the new ext3 root partition on /mnt/sysimage, and
yet it still claims that there is not enough space!  The exact
error message is:

  You don't appear to have enough disk space to install the
  packages you've selected. You need more space on the following
  file systems:

  Mount Point     Space Needed
  /               1683 M

                 OK

However, as you will see from the attached outputs of the mount
and df commands run on tty2, this is most definitely untrue!
Comment 6 Adam Spiers 2002-10-28 12:56:16 EST
Created attachment 82404 [details]
Output of df run on tty2 after bogus anaconda error occurred
Comment 7 Adam Spiers 2002-10-28 12:57:25 EST
Created attachment 82405 [details]
Output of mount run on tty2 after bogus anaconda error occurred
Comment 8 Adam Spiers 2002-10-28 13:37:51 EST
Ahhhhhhhhh ... !

When it said "space needed: 1683MB", it meant 1683 *more* MB,
not 1683MB in total.  And full install of RedHat 8.0 is
close on 5GB!  (When did it get so huge?!)

So the original problem stands - there *is* something
funny with ext3, but you can ignore today's comments and
attachments.  Could it be something to do with the fact
that I was using RedHat 8.0's anaconda to perform an install
of Advanced Server 2.1?
Comment 9 Jeremy Katz 2002-10-29 08:35:40 EST
There is NO way that will work.  The modules on the second stage (including the
ext3 module) won't match the version of your running kernel and so can't be
loaded if you do this.

Note You need to log in before you can comment on or make changes to this bug.