Bug 753393 - Transparent bg settings description is confusing
Transparent bg settings description is confusing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-12 02:58 EST by Paweł Prażak
Modified: 2012-01-11 20:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 20:20:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (129.27 KB, image/png)
2011-11-12 03:16 EST, Paweł Prażak
no flags Details
Mock up (29.86 KB, image/png)
2011-11-12 03:17 EST, Paweł Prażak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 663906 None None None Never

  None (edit)
Description Paweł Prażak 2011-11-12 02:58:50 EST
Description of problem:
It looks like this:

- Transparent Background
  Shade transparent or image background:
  None ----------------------------------------------------------- Max

1. What does 'shade transparent' actually mean? A shade of transparent? Doesn't sound right.
2. Setting is named 'Transparent Background' but setting it to 'None' causes the background to be 0%, fully transparent background and setting to 'Maximum' causes the bg to be at 100% transparency, so it is not transparent bg.
3. The whole tab is tricky because the slider bellow is active even if the radio button on transparent bg is not checked.

Version-Release number of selected component (if applicable):
GNOME 3.2 (but I think it is not a recent change)

How reproducible:
Always

Steps to Reproduce:
1. Open the background settings of gnome-terminal
2. (see description above)
3.
  
Actual results:
Confusing description with reverse logic and 
I'll attach screanshot illustrating the problem

Expected results:
Clear and simple settings description with one obvious interpretation.
I'll attach a mock-up of expected results.
Comment 1 Paweł Prażak 2011-11-12 03:16:44 EST
Created attachment 533218 [details]
Screenshot
Comment 2 Paweł Prażak 2011-11-12 03:17:08 EST
Created attachment 533219 [details]
Mock up
Comment 3 Paweł Prażak 2011-11-12 03:18:39 EST
(In reply to comment #2)
> Created attachment 533219 [details]
> Mock up

Where setting Transparency: None should do what is says, set bg transparency to None, so the bg is at 100%
Comment 4 Paweł Prażak 2011-11-12 03:25:03 EST
I've just realized that maybe it would be better to fill this bug upstream.
Comment 5 Paweł Prażak 2011-11-12 03:29:43 EST
https://bugzilla.gnome.org/show_bug.cgi?id=663906
Comment 6 Fedora Admin XMLRPC Client 2012-01-10 10:46:39 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2012-01-10 10:49:39 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Matthias Clasen 2012-01-11 20:20:58 EST
Thanks, tracking this upstream is better, indeed

Note You need to log in before you can comment on or make changes to this bug.