Bug 75343 - /usr/tmp has to be a symlink otherwise filesystem won't install
Summary: /usr/tmp has to be a symlink otherwise filesystem won't install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: filesystem   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 71457 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-07 14:27 UTC by Mathieu Chouquet-Stringer
Modified: 2014-03-17 02:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 14:27:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mathieu Chouquet-Stringer 2002-10-07 14:27:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
If you attempt to upgrade an existing system (in my case, it was 7.3) and if
/usr/tmp is a directory instead of a symlink (to /var/tmp), filesystem won't
install and thus the install will die with a "fatal error"...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a directory: /usr/tmp
2. try to upgrade the filesystem package (via rpm or through the install)
3. Profit! (kidding, well it fails)
	

Actual Results:  I tried to do the upgrade manually (rpm -Uvh) and that's how I
discovered the problem (cpio chokes on the directory).

Expected Results:  At least the install shouldn't fail because of this issue.

Additional info:

If memory serves I think it's not the first time I've been bitten by this bug
while doing an upgrade (so it could be an "old" bug).

Comment 1 Bill Nottingham 2002-10-07 19:11:33 UTC
RPM currently can't replace a directory with a symlink.

Comment 2 Bill Nottingham 2002-10-16 19:45:56 UTC
*** Bug 76029 has been marked as a duplicate of this bug. ***

Comment 3 Petri T. Koistinen 2002-10-17 23:55:17 UTC
Why is this closed?

Comment 4 Bill Nottingham 2002-10-18 01:39:42 UTC
It's not a fixable thing with filesystem; this is a result of the way rpm works.

Comment 5 Need Real Name 2002-10-24 13:30:19 UTC
I hit a similar problem because of /usr/lib/X11 which was replaced by a 
directory when I installed an application.



Comment 6 Petri T. Koistinen 2002-10-24 16:52:02 UTC
Bug 76029 is marked as rpm bug.

Comment 7 Bill Nottingham 2002-11-20 21:16:20 UTC
*** Bug 71457 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.