Bug 75364 - Not sure if this is LOGROTATE or MAILMAN bug (or even Sendmail)
Not sure if this is LOGROTATE or MAILMAN bug (or even Sendmail)
Status: CLOSED DUPLICATE of bug 68917
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 14:19 EDT by Aaron Freed
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-30 10:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Directory listing of "stuffed" /var/log/mailman (3.24 MB, patch)
2002-10-07 14:21 EDT, Aaron Freed
no flags Details | Diff

  None (edit)
Description Aaron Freed 2002-10-07 14:19:27 EDT
Description of Problem:   
Error logs are accumulating in the /var/log/mailman directory.   
They have names like this:   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.2.4.1.2   
-rw-rw-r--    1 mailman  mailman         0 Sep 29 05:01   
error.1.1.1.1.1.1.3.2.4.1.2.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 15 04:05   
error.1.1.1.1.1.1.3.2.4.1.3   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.2.4.2   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.2.4.2.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 29 05:01   
error.1.1.1.1.1.1.3.2.4.2.1.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 22 04:16   
error.1.1.1.1.1.1.3.2.4.2.2   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.2.4.3   
-rw-rw-r--    1 mailman  mailman         0 Sep 29 05:01   
error.1.1.1.1.1.1.3.2.4.3.1   
-rw-rw-r--    1 mailman  mailman         0 Sep  8 04:03   
error.1.1.1.1.1.1.3.2.4.4   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37 error.1.1.1.1.1.1.3.3   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1.1   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1.1.1   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1.1.1.1   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1.1.1.1.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 29 05:01   
error.1.1.1.1.1.1.3.3.1.1.1.1.1.1.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 22 04:16   
error.1.1.1.1.1.1.3.3.1.1.1.1.1.2   
-rw-rw-r--    1 mailman  mailman         0 Oct  6 07:37   
error.1.1.1.1.1.1.3.3.1.1.1.1.2   
-rw-rw-r--    1 mailman  mailman         0 Sep 29 05:01   
error.1.1.1.1.1.1.3.3.1.1.1.1.2.1   
-rw-rw-r--    1 mailman  mailman         0 Sep 15 04:05   
error.1.1.1.1.1.1.3.3.1.1.1.1.3   
   
These files are present only on some servers, but not on others.  Servers   
running RedHat 7.3 seem to be the ones that contain these files.   
   
OTHER SYMPTOMS:   
Sometimes, logrotate seems to run and take up a tremendous amount of CPU and 
disk (albeit for only about 2 to 10 minutes.  I am assuming that this is 
caused by it dealing with all these mailman error files.) 
   
   
Version-Release number of selected component (if applicable):   
 logrotate-3.6.4.1 mailman-2.0.9-1, mailman-2.0.13-1 
 
Happens with the same version of logrotate and several versions of mailman. 
 
   
How Reproducible:   
  Seems to consistently happen under RedHat 7.3 (all servers I've looked at.) 
It definately does NOT have something to do with  
 
root:     afreed@voicesignal.com 
 
in /etc/aliases, because this entry is NOT present on my laptop, which is 
experiencing the same problem. 
 
 
   
Steps to Reproduce:   
1. Problem appears to be present on Redhat 7.3 servers that have the 
aforementioned versions of mailman and logrotate.   
2.   Cannot remove the logs through conventional means as this results: 
 
[root@montpellier root]# cd /var/log/mailman 
[root@montpellier mailman]# rm -Rf * 
bash: /bin/rm: Argument list too long 
[root@montpellier mailman]# ls -al | wc -l 
  31675 
 
31675 is not a huge number of files.  Unless RM is hardwired to not remove 
files in a directory with the s flag set for Groups, then this might well be a 
bug with RM.  (I CAN remove the files one-by-one or a few at a time.) 
 
 
 
3.    
   
 
Actual Results:   
 error files accumulate, eventually to the point where all available inodes 
are used up and no more data can be stored in /var/log/, which, in turn, can 
wedge the server, cause scripts to fail and otherwise wreak mayhem and 
contumily.  
   
Expected Results:   
The files should be cleaned up and removed by normal logrotate operation.  It 
seems to be unique to mailman errors, though.  I have seen no other logsfiles 
accumulating in any other directories. 
 
 
   
   
Additional Information:   
Available upon request.
Comment 1 Aaron Freed 2002-10-07 14:21:58 EDT
Created attachment 79229 [details]
Directory listing of "stuffed" /var/log/mailman
Comment 2 Need Real Name 2002-10-17 18:28:38 EDT
This is a bug with the confiog files in redhat - you need to 
edit /etc/logrotate.d/mailman from "/var/log/mailman/*" to explicitly name the 
files you want to rotate eg "/var/log/mailman/error"

I had 350,000 logfiles in mailman this morning - I've been killing off 
logrotate lately as it's been hogging all the CPU , now I know why.


Check your mgetty setup if your using it too - it has a wildcard in it as well.
Comment 3 Paul Moore 2002-10-21 01:59:04 EDT
I've diagnosed this problem on at least 2 RH 7.3 systems (and I assume it 
occurs on all of them). The system eventually runs out of inodes on /var and 
chews up huge amounts of CPU when doing log rotation. 

Processes such as dhcpd and syslog that both periodically write to /var fail 
since they can't create a file.

Inodes increase logarithmically, which explains why my RH 7.3 have/will 
experience this problem at roughly the same time.
Comment 4 Scott Glenn 2002-10-30 10:38:51 EST
Here's a command line for removing the files.
I'm sure there is more than one way to do it.

find /var/log/mailman -name error\* -exec /bin/rm {} \;

This works on the bash command line - your shell may require different
quote/escape chars.
Comment 5 Elliot Lee 2002-12-10 13:07:00 EST

*** This bug has been marked as a duplicate of 68917 ***

Note You need to log in before you can comment on or make changes to this bug.