Bug 75427 - Oops with ppp and updatedb
Oops with ppp and updatedb
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 10:14 EDT by James Antill
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 11:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2002-10-08 10:14:20 EDT
Description of Problem:
 Got oops in iget4 when, ppp had just come up, and I did ifup cipcb0 then got...

Oct  8 09:54:49 rh kernel: Unable to handle kernel paging request at virtual
address 36322862
Oct  8 09:54:49 rh kernel:  printing eip:
Oct  8 09:54:49 rh kernel: c01556a8
Oct  8 09:54:49 rh kernel: *pde = 00000000
Oct  8 09:54:49 rh kernel: Oops: 0000
Oct  8 09:54:49 rh kernel: ppp_deflate zlib_deflate ppp_async ppp_generic slhc
sr_mod radeon agpgart seri
Oct  8 09:54:49 rh kernel: CPU:    0
Oct  8 09:54:49 rh kernel: EIP:    0010:[<c01556a8>]    Not tainted
Oct  8 09:54:49 rh kernel: EFLAGS: 00010207
Oct  8 09:54:49 rh kernel:
Oct  8 09:54:49 rh kernel: EIP is at find_inode [kernel] 0x28 (2.4.18-14)
Oct  8 09:54:49 rh kernel: eax: 00000000   ebx: 3632283a   ecx: 00007fff   edx:
c25c0000
Oct  8 09:54:49 rh kernel: esi: 00000000   edi: c25cb118   ebp: 001404b6   esp:
d5a81e4c
Oct  8 09:54:49 rh kernel: ds: 0018   es: 0018   ss: 0018
Oct  8 09:54:50 rh kernel: Process updatedb (pid: 3376, stackpage=d5a81000)
Oct  8 09:54:50 rh kernel: Stack: 00000000 d30d5620 c250a400 001404b6 c25cb118
c250a400 001404b6 c01559d4
Oct  8 09:54:50 rh kernel:        c250a400 001404b6 c25cb118 00000000 00000000
001404b6 d6b9d560 d70188c0
Oct  8 09:54:50 rh kernel:        d6b9d560 e083de5c c250a400 001404b6 00000000
00000000 d6c0a954 fffffff4
Oct  8 09:54:50 rh kernel: Call Trace: [<c01559d4>] iget4 [kernel] 0x54
(0xd5a81e68))
Oct  8 09:54:50 rh kernel: [<e083de5c>] ext3_lookup [ext3] 0x7c (0xd5a81e90))
Oct  8 09:54:50 rh kernel: [<c014a5b7>] real_lookup [kernel] 0xc7 (0xd5a81eb0))
Oct  8 09:54:50 rh kernel: [<c014ab1f>] link_path_walk [kernel] 0x40f (0xd5a81ecc))
Oct  8 09:54:50 rh kernel: [<c014b109>] path_lookup [kernel] 0x39 (0xd5a81f0c))
Oct  8 09:54:50 rh kernel: [<c014b3a9>] __user_walk [kernel] 0x49 (0xd5a81f1c))
Oct  8 09:54:50 rh kernel: [<c01474ff>] vfs_lstat [kernel] 0x1f (0xd5a81f38))
Oct  8 09:54:50 rh kernel: [<c0147b5b>] sys_lstat64 [kernel] 0x1b (0xd5a81f70))
Oct  8 09:54:50 rh kernel: [<c0120001>] request_resource [kernel] 0x21 (0xd5a81f84))
Oct  8 09:54:50 rh kernel: [<c010910f>] system_call [kernel] 0x33 (0xd5a81fc0))
Oct  8 09:54:51 rh kernel:
Oct  8 09:54:51 rh kernel:
Oct  8 09:54:51 rh kernel: Code: 39 6b 28 89 de 75 f1 8b 44 24 20 39 83 94 00 00
00 75 e5 8b
Oct  8 09:54:51 rh ifup-cipcb: cipcb started for cipcb0
Oct  8 09:54:51 rh ciped-cb[3854]: CIPE daemon vers 1.4.5 (c) Olaf Titz 1996-2000


Version-Release number of selected component (if applicable):
kernel-2.4.18-14

How Reproducible:
Unknown

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

 I was running 2.4.18-16.8.0 a bit ago as I thought it was an unpushed arrata
for 8.0 (I got it before 8.0 was official). Anyway that gave the following which
looks similar...

Oct  7 16:51:00 rh kernel: Unable to handle kernel paging request at virtual
address 5d8bf089
Oct  7 16:51:00 rh kernel:  printing eip:
Oct  7 16:51:00 rh kernel: c0117e43
Oct  7 16:51:00 rh kernel: *pde = 00000000
Oct  7 16:51:00 rh kernel: Oops: 0000
Oct  7 16:51:00 rh kernel: cipcb ppp_deflate zlib_deflate ppp_async ppp_generic
slhc sr_mod i810_audio ac
Oct  7 16:51:00 rh kernel: CPU:    0
Oct  7 16:51:00 rh kernel: EIP:    0010:[<c0117e43>]    Not tainted
Oct  7 16:51:00 rh kernel: EFLAGS: 00010087
Oct  7 16:51:00 rh kernel:
Oct  7 16:51:00 rh kernel: EIP is at __wake_up [kernel] 0x23 (2.4.18-16.8.0)
Oct  7 16:51:00 rh kernel: eax: d77c4b18   ebx: d75c4b18   ecx: 00000001   edx:
5d8bf089
Oct  7 16:51:00 rh kernel: esi: d77c4b18   edi: 00000003   ebp: d7173e3c   esp:
d7173e20
Oct  7 16:51:00 rh kernel: ds: 0018   es: 0018   ss: 0018
Oct  7 16:51:00 rh kernel: Process galeon-bin (pid: 4136, stackpage=d7173000)
Oct  7 16:51:00 rh kernel: Stack: d4c6cf60 d03fd600 00000001 00000286 00000000
d77c4a80 c2526400 c25e5938
Oct  7 16:51:00 rh kernel:        c0155885 d77c4a80 002aab8d c25e5938 00000000
00000000 00000000 c25e5938
Oct  7 16:51:00 rh kernel:        c2526400 002aab8d c0155a5b c2526400 002aab8d
c25e5938 00000000 00000000
Oct  7 16:51:00 rh kernel: Call Trace: [<c0155885>] get_new_inode [kernel] 0x145
(0xd7173e40))
Oct  7 16:51:00 rh kernel: [<c0155a5b>] iget4 [kernel] 0xdb (0xd7173e68))
Oct  7 16:51:00 rh kernel: [<e0822e5c>] ext3_lookup [ext3] 0x7c (0xd7173e90))
Oct  7 16:51:00 rh kernel: [<c014a5b7>] real_lookup [kernel] 0xc7 (0xd7173eb0))
Oct  7 16:51:00 rh kernel: [<c014ab1f>] link_path_walk [kernel] 0x40f (0xd7173ecc))
Oct  7 16:51:00 rh kernel: [<c014b109>] path_lookup [kernel] 0x39 (0xd7173f0c))
Oct  7 16:51:00 rh kernel: [<c014b3a9>] __user_walk [kernel] 0x49 (0xd7173f1c))
Oct  7 16:51:00 rh kernel: [<c014749f>] vfs_stat [kernel] 0x1f (0xd7173f38))
Oct  7 16:51:00 rh kernel: [<c012d6d3>] unmap_fixup [kernel] 0x163 (0xd7173f3c))
Oct  7 16:51:00 rh kernel: [<c012da4e>] do_munmap [kernel] 0x2be (0xd7173f58))
Oct  7 16:51:00 rh kernel: [<c0147b1b>] sys_stat64 [kernel] 0x1b (0xd7173f70))
Oct  7 16:51:00 rh kernel: [<c012daca>] sys_munmap [kernel] 0x4a (0xd7173fa4))
Oct  7 16:51:00 rh kernel: [<c010a22e>] math_state_restore [kernel] 0x1e
(0xd7173fb8))
Oct  7 16:51:00 rh kernel: [<c010911f>] system_call [kernel] 0x33 (0xd7173fc0))
Oct  7 16:51:00 rh kernel:
Oct  7 16:51:00 rh kernel:
Oct  7 16:51:00 rh kernel: Code: 8b 02 85 c7 75 17 8b 1b 39 f3 75 f1 ff 75 f0 9d
83 c4 10 5b
Comment 1 Stephen Tweedie 2002-10-08 11:43:01 EDT
Random corruption in a data structure that usually points to bad memory.  I'd
try a memtest86 run first.  There certainly _could_ be something else to it, but
hardware is the cause in the vast majority of this sort of oops.  How often do
you see this?  Have you ever seen it on older kernels?
Comment 2 James Antill 2002-10-09 12:55:57 EDT
 Well after finding random corruption in a couple of system files, I quickly ran
memtest86 and confirmed that I need new memory.

Note You need to log in before you can comment on or make changes to this bug.