Bug 754491 - F16 does not boot under Xen under D945GCLF2
F16 does not boot under Xen under D945GCLF2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
16
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 11:53 EST by Joerg
Modified: 2012-03-23 09:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 09:27:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xen output captured via console=com1 (119.35 KB, application/octet-stream)
2011-11-16 11:53 EST, Joerg
no flags Details
Initial logfile with boot options (8.01 KB, text/x-log)
2011-11-16 15:51 EST, Joerg
no flags Details
second logfile with requested boot options (33.21 KB, text/x-log)
2011-11-16 15:52 EST, Joerg
no flags Details

  None (edit)
Description Joerg 2011-11-16 11:53:12 EST
Created attachment 534053 [details]
xen output captured via console=com1

Description of problem:
Starting F16 kernel 3.1.1 under xen 4.1.2 does not work. After starting xen no additional messages are displayed. 

Version-Release number of selected component (if applicable):
see above

How reproducible:
every time

Steps to Reproduce:
1. install xen
2. choose f16 with xen in grub
3.
  
Actual results:
Nothing, no message at all, no automatic reboot

Expected results:
f16 running as dom0

Additional info:
xen logfile attached
Comment 1 Konrad Rzeszutek Wilk 2011-11-16 13:52:25 EST
Did you look in http://wiki.xen.org/xenwiki/XenParavirtOps to follow the troubleshoot guide and capture some details? 

Do you get any details if you provide 'console=hvc0 debug loglevel=8' on the Linux line? And on the Xen hypervisor line youy have 'sync_console console_to_ring loglvl=all'?

What hardware is this?

Is there a reason for using acpi=ht?

Hmm, this is not reassuring:
(XEN) ERROR: Unable to locate IOAPIC for GSI 9
(XEN) No IOAPIC for GSI 9

What are the arguments for the Linux command line?

Have you added some extra ones?
Comment 2 Joerg 2011-11-16 15:51:15 EST
Created attachment 534083 [details]
Initial logfile with boot options
Comment 3 Joerg 2011-11-16 15:52:03 EST
Created attachment 534084 [details]
second logfile with requested boot options
Comment 4 Joerg 2011-11-16 15:55:21 EST
This is a Intel D945GCLF2 Motherboard with 2 Atom CPUs.

I have read in the net that my issue is related to acpi. So I have tried some options.

My initial logfile was holding several attempts because I forgot to truncate it.

I have attached one logfile with the boot options and the messages only from this attempt.

A second file is attached with your requested options and the messages from this run.
Comment 5 Konrad Rzeszutek Wilk 2011-11-16 17:03:06 EST
Interesting. There is another bug with an Atom machine not booting either- Bug #745961	that has the same exact error:

[    0.143986] reserve RAM buffer: 00000001097be000 - 000000010bffffff (XEN) domain_crash_sync called from entry.S (ff1d9724)

(XEN) Domain 0 (vcpu#0) crashed on cpu#1:


I found out that if I update the kernel to 3.2-rc1 it works just great.
Comment 6 Joerg 2011-11-17 04:14:03 EST
Great news !

But how do I update the kernel to 3.2-rc1 ?
I cannot find that version in the repos.

Note You need to log in before you can comment on or make changes to this bug.