This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 754496 - RQUOTAD_PORT ignored in /etc/sysconfig/nfs and other port options removed
RQUOTAD_PORT ignored in /etc/sysconfig/nfs and other port options removed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 12:15 EST by Colin Simpson
Modified: 2012-03-22 15:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 15:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Colin Simpson 2011-11-16 12:15:12 EST
Description of problem:

The older /etc/sysconfig/nfs file used to contain many PORT options to allow NFS to be more firewall friendly (so you can fix the port numbers).

Since the change to systemd a couple of these have gone:

MOUNTD_PORT
STATD_PORT

These can be fixed in F16 with:

RPCMOUNTDOPTS="-p 4003"
STATDARG="-p 4001"

But it is less clear perhaps. Was this change intended ?

Also RQUOTAD_PORT is still present in the sample config file this file but doesn't work! You have to use similar to above:

RPCRQUOTADOPTS="-p 4004"

to fix it's port. So either RQUOTAD_PORT should be removed from the sample /etc/sysconfig/nfs or else made to work along with a readding in MOUNTD_PORT and  
STATD_PORT.

The lockd ports still can be fixed in this file (LOCKD_TCPPORT and LOCKD_UDPPORT ) and work as intended which seems inconsistent with the other NFS services no longer having port setting config options.
Comment 1 Steve Dickson 2011-11-16 16:14:48 EST
(In reply to comment #0)
> Description of problem:
> 
> The older /etc/sysconfig/nfs file used to contain many PORT options to allow
> NFS to be more firewall friendly (so you can fix the port numbers).
> 
> Since the change to systemd a couple of these have gone:
> 
> MOUNTD_PORT
> STATD_PORT
> 
> These can be fixed in F16 with:
> 
> RPCMOUNTDOPTS="-p 4003"
> STATDARG="-p 4001"
> 
> But it is less clear perhaps. Was this change intended ?
Unfortunately yes. Systemd scripts lack any programming support like if-then clauses so there is no way of testing if a variable is set or not.
 
> 
> Also RQUOTAD_PORT is still present in the sample config file this file but
> doesn't work! You have to use similar to above:
> 
> RPCRQUOTADOPTS="-p 4004"
> 
> to fix it's port. So either RQUOTAD_PORT should be removed from the sample
> /etc/sysconfig/nfs or else made to work along with a readding in MOUNTD_PORT
> and  
> STATD_PORT.
I'll do the latter...

> 
> The lockd ports still can be fixed in this file (LOCKD_TCPPORT and
> LOCKD_UDPPORT ) and work as intended which seems inconsistent with the other
> NFS services no longer having port setting config options.
Well this is another systemd-ism... To get the lockd port setting to work, I actually have the systemd script call a shell script in which those variables 
are used. So those variables are actually shell script variables that 
are used in a command line to /sbin/sysctl in
      /usr/lib/nfs-utils/scripts/nfs-lock.preconfig
Comment 2 Steve Dickson 2011-11-16 16:18:55 EST
(In reply to comment #1)
> 
> > 
> > Also RQUOTAD_PORT is still present in the sample config file this file but
> > doesn't work! You have to use similar to above:
> > 
> > RPCRQUOTADOPTS="-p 4004"
> > 
> > to fix it's port. So either RQUOTAD_PORT should be removed from the sample
> > /etc/sysconfig/nfs or else made to work along with a readding in MOUNTD_PORT
> > and  
> > STATD_PORT.
> I'll do the latter...
After further review I'm going to do the former... I just remove it...

Note You need to log in before you can comment on or make changes to this bug.