This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 75457 - kpanel crashes after trying to remove applet/button
kpanel crashes after trying to remove applet/button
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 75369 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 14:54 EDT by Kyle
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle 2002-10-08 14:54:37 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
kpanel crashes after trying to add or remove applet....								 
 
Version-Release number of selected component (if applicable): 3.03-13 
 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
1. right click on kpanel  
2. add applet/button 
3. remove applet/button 
4. crashes.. 
5. panel reappears 
6. try to remove 
7. crashes  
8. panel never appears again 
	 
 
Actual Results:  (no debugging symbols found)...[New Thread 8192 (LWP 3205)] 
0x420ae169 in wait4 () from /lib/i686/libc.so.6 
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6 
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6 
#2  0x40e12c63 in waitpid () from /lib/i686/libpthread.so.0 
#3  0x406231a5 in KCrash::defaultCrashHandler(int) () 
   from /usr/lib/libkdecore.so.4 
#4  <signal handler called> 
#5  0x40b578f9 in QString::QString(QString const&) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#6  0x41739a27 in PanelRemoveButtonMenu::slotAboutToShow() () 
   from /usr/lib/kicker.so 
#7  0x41738f60 in PanelRemoveButtonMenu::qt_invoke(int, QUObject*) () 
   from /usr/lib/kicker.so 
#8  0x408e5d6b in QObject::activate_signal(QConnectionList*, QUObject*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#9  0x408e5c57 in QObject::activate_signal(int) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#10 0x40bc04ce in QPopupMenu::aboutToShow() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#11 0x409d2eab in QPopupMenu::subMenuTimer() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#12 0x40bc05f4 in QPopupMenu::qt_invoke(int, QUObject*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#13 0x41733dad in RemoveContainerMenu::qt_invoke(int, QUObject*) () 
   from /usr/lib/kicker.so 
#14 0x408e5d6b in QObject::activate_signal(QConnectionList*, QUObject*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#15 0x408e5c57 in QObject::activate_signal(int) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#16 0x40baeb4b in QTimer::timeout() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#17 0x40906792 in QTimer::event(QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#18 0x40891c49 in QApplication::internalNotify(QObject*, QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#19 0x408914f1 in QApplication::notify(QObject*, QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#20 0x405b79a6 in KApplication::notify(QObject*, QEvent*) () 
   from /usr/lib/libkdecore.so.4 
#21 0x40834a88 in qt_activate_timers() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#22 0x40832330 in QApplication::processNextEvent(bool) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#23 0x40893280 in QApplication::enter_loop() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#24 0x409d39b6 in QPopupMenu::exec(QPoint const&, int) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#25 0x416e21dc in Panel::showPanelMenu(QPoint) () from /usr/lib/kicker.so 
#26 0x416f0245 in PanelContainer::eventFilter(QObject*, QEvent*) () 
   from /usr/lib/kicker.so 
#27 0x408e3e5e in QObject::activate_filters(QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#28 0x408e3d81 in QObject::event(QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#29 0x4091a2ec in QWidget::event(QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#30 0x40891c49 in QApplication::internalNotify(QObject*, QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#31 0x40891363 in QApplication::notify(QObject*, QEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#32 0x405b79a6 in KApplication::notify(QObject*, QEvent*) () 
   from /usr/lib/libkdecore.so.4 
#33 0x40835b46 in QETWidget::translateMouseEvent(_XEvent const*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#34 0x408329b6 in QApplication::x11ProcessEvent(_XEvent*) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#35 0x4083252f in QApplication::processNextEvent(bool) () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#36 0x40893280 in QApplication::enter_loop() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#37 0x4083202d in QApplication::exec() () 
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3 
#38 0x416dea97 in main () from /usr/lib/kicker.so 
#39 0x0804cb9f in strcpy () 
#40 0x0804d8bb in strcpy () 
#41 0x0804dd7c in strcpy () 
#42 0x0804eb40 in strcpy () 
#43 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6 
 
 
Additional info:
Comment 1 Ngo Than 2002-10-08 15:36:41 EDT
strange, i cannot reproduce it on my local machine with 8.0 release. Are you
sure you have installed following rpms on your machine?

- qt-3.0.5-17
- kdelibs-3.0.3-8
- kdebase-3.0.3-13
Comment 2 Ngo Than 2002-10-08 16:24:50 EDT
*** Bug 75369 has been marked as a duplicate of this bug. ***
Comment 3 wifflefan_ml 2002-10-09 17:48:51 EDT
fwiw, i have all of those packages installed on my machine, and i have been able
to reproduce the error on a machine with an unmodified, new installation
Comment 4 Sammy 2002-10-16 09:59:52 EDT
I have filed this bug too. It crashes every time with qt-3.0.5-17, kdelibs-3.0.4-2, 
and kdebase-3.0.4-1. It also crashed with the above rpms.
Comment 5 Bill Nottingham 2006-10-18 14:25:52 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.