Bug 7547 - whatis database not set up on install
whatis database not set up on install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 11:14 EST by David Balažic
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-08 09:53:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 1999-12-03 11:14:38 EST
The whatis database is not set up on install.
'apropos' and 'whatis' does not work.
Running 'makewhatis -w' fixes it.
I know that it is called from cron.daily, but several hours can
pass before that , and a new users needs this help in the first
hours most !
Comment 1 Bernhard Rosenkraenzer 1999-12-08 09:53:59 EST
This is intentional. We can't include a prebuild whatis database because we
can't predict what man pages will be installed, and running makewhatis from the
installer would just slow down the installation; cron does a better job here.

If you have a better solution, let me know...
Comment 2 David Balažic 1999-12-08 10:42:59 EST
How about running makewhatis on first boot ?
The calling script should then be deleted or altered, something
like the Wind*ws RunOnce things :-)

Note You need to log in before you can comment on or make changes to this bug.