Bug 75474 - Workspace Switcher doesn't save settings
Workspace Switcher doesn't save settings
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 76316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 18:03 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-24 13:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-08 18:03:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.4.1) Gecko/20020518
Netscape6/6.2.3

Description of problem:
When using Sawfish as the window manager, the workspace switcher applet only
shows one workspace, and it does not save any changes you make to the switcher
configuration when a user logs out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install redhat 8.0 without metacity or other wm's, but with sawfish
2.Login to Gnome 2 desktop.
3.Workspace switcher shows only one desktop workspace, modifying the setting
works for the duration of that session, but do not get saved.
	

Actual Results:  Workspace switcher failed to save configuration settings

Expected Results:  The default should have provided 4 workspaces, and it should
have saved the settings changes

Additional info:

Stock Redhat 8.0 on five different systems (P2-200, P3-800, P4-1.7ghz, Duron
900, Athlon 1700).

Note: A workaround is to remove sawfish and use another window manager (metacity
works correctly).
Comment 1 Havoc Pennington 2002-10-08 18:24:13 EDT
Filed as http://bugzilla.gnome.org/show_bug.cgi?id=95224

We will get the fix with new upstream versions, when available.
Comment 2 Bill Nottingham 2002-11-07 22:51:00 EST
*** Bug 76316 has been marked as a duplicate of this bug. ***
Comment 3 Leigh Orf 2004-05-23 14:44:02 EDT
Is this bug ever going to be fixed? Still there in FC2.
Comment 4 Havoc Pennington 2004-05-24 13:47:51 EDT
We will not be authoring Sawfish fixes, no. Sawfish has been provided
on an as-is basis for a while now. If there's a new Sawfish version
that fixes it, however, I'm happy to build it in the distribution.

The bug resolution is wrong, we didn't have UPSTREAM probably when
this was closed; I'll change it. See the earlier comment with link to
the upstream bug report.

Note You need to log in before you can comment on or make changes to this bug.