Bug 75479 - xmms cdaudio volume control doesn't work
xmms cdaudio volume control doesn't work
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 18:36 EDT by Shawn Walker
Modified: 2013-03-05 22:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Walker 2002-10-08 18:36:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When using XMMS to play audio cd's the volume control has no effect on playback
volume. This is in my case is because XMMS assumes that your cdrom audio
connector is connected to the analog cdrom input, however, many newer soundcards
(such as the SoundBlaster Audigy) and other systems can have their cdrom audio
connected via an SPDIF connector (SOUND_MIXER_DIGITAL_1 in OSS speak for my
card) which provides high quality digital audio playback.

This problem could be solved if there was an option in the cdaudio plugin to
have XMMS use the digital 1 mixer instead of the cdrom mixer channel. Which
allows the volume control to actually function as it's intended to. This only
applies in the case where "OSS Mixer" is selected.

I have tried the CDROM drive volume option and that doesn't work. 

I've downloaded the XMMS source rpm and and modified the source of the cdaudio
plugin to do this (not as an option, since I just wanted proof it could be done,
only had to change 4 lines in the plugin). So I know it can be done. I'm even
willing to provide a patch that will do this so you don't have to :) I just need
to know how you want it to be implemented (interface wise), and if I write it
that you will (hopefully) accept the patch if it is satisfactory for inclusion
in a later release...

Thanks.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start XMMS
2. Add tracks from audio cd to playlist
3. Play a track
4. Attempt to adjust volume

Expected Results:  Volume should be raised and lowered.

Additional info:
Comment 1 Colin Walters 2004-09-27 14:51:59 EDT
Has this been solved in a more recent version of xmms?  I don't have
the hardware so I can't test.
Comment 2 Bill Nottingham 2006-10-18 14:34:42 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.