Bug 75484 - php-4.1.2-7.0.3 requires a whole bunch of DEVEL libraries previous versions did NOT.
php-4.1.2-7.0.3 requires a whole bunch of DEVEL libraries previous versions d...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 19:26 EDT by Max TenEyck Woodbury
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 19:26:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max TenEyck Woodbury 2002-10-08 19:26:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Win95; U)

Description of problem:
Error message generated by rpm -Fhv php-4.1.2-7.0.3.i386.rpm with previous version of php installed:

error: failed dependencies:
        bzip2-devel >= 1.0 is needed by php-4.1.2-7.0.3
        freetype-devel >= 1.3.1-7 is needed by php-4.1.2-7.0.3
        gd-devel is needed by php-4.1.2-7.0.3
        gdbm-devel is needed by php-4.1.2-7.0.3
        gmp-devel is needed by php-4.1.2-7.0.3
        imap-devel >= 2000-9 is needed by php-4.1.2-7.0.3
        krb5-devel is needed by php-4.1.2-7.0.3
        libjpeg-devel is needed by php-4.1.2-7.0.3
        libpng-devel is needed by php-4.1.2-7.0.3
        mysql-devel is needed by php-4.1.2-7.0.3
        openssl-devel is needed by php-4.1.2-7.0.3
        postgresql-devel is needed by php-4.1.2-7.0.3
        pspell-devel is needed by php-4.1.2-7.0.3
        ucd-snmp is needed by php-4.1.2-7.0.3
        ucd-snmp-utils is needed by php-4.1.2-7.0.3
        ucd-snmp-devel is needed by php-4.1.2-7.0.3
        unixODBC-devel is needed by php-4.1.2-7.0.3
        zlib-devel is needed by php-4.1.2-7.0.3



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have previous version of php installed.
2. Do NOT have devel libs installed.
3. Try to 'freshen' or 'upgrade' the recent version of php.
	

Actual Results:  See description above.

Expected Results:  It should upgrade without having to install all those extra libraries.

Additional info:

The upgrade is needed to fix a number of security issues with php.
Comment 1 Joe Orton 2002-10-09 04:56:43 EDT
These packages were fixed in an update to RHSA-2002:035, the package was
php-4.1.2-7.0.4.

Note You need to log in before you can comment on or make changes to this bug.