Bug 75497 - Tried to insert ipchains module and it can't find IO?
Tried to insert ipchains module and it can't find IO?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ipchains (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 01:00 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 01:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-09 01:00:39 EDT
Description of Problem: Can't insert IPChains module


Version-Release number of selected component (if applicable): ipchains-1.3.10-16

How Reproducible: Every time tried


Steps to Reproduce:
1. rpm -e ipchains-1.3.10-16
2. rpm -ivh ipchains-1.3.10-16.i386.rpm (OK - installs)
3. insmod ipchains (Invalid IO or such)

Actual Results: Unable to complete request


Expected Results: OK


Additional Information:
Here is what was returned to me...




__________________
login as: root
Sent username "root"
root@192.168.1.1's password:
Access denied
root@192.168.1.1's password:
Last login: Tue Oct  8 22:07:35 2002
[root@timmay root]# cd /download
[root@timmay download]# ls
aim-1.5.234-1.i386.rpm       nc100.exe
aim-1.5.234-1.i386.tgz       openssl-0.9.6g
ddclient-3.6.2-1.noarch.rpm  openssl-0.9.6g.tar.gz
ettercap-0.6.7               openssl-engine-0.9.6g
ettercap-0.6.7.tar.gz        openssl-engine-0.9.6g.tar.gz
ipchains-1.3.10-16.i386.rpm  usermin-0.950-1.noarch.rpm
iptables-1.2.6a-2.i386.rpm   webmin-1.020-1.noarch.rpm
latest_linux.adp_files       ymsgr.exe
linuxconf-1.28r4-1.i386.rpm
[root@timmay download]# rpm -e ipchains-1.3.10-16
[root@timmay download]# rpm -ivh ipchains-1.3.10-16.i386.rpm
warning: ipchains-1.3.10-16.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:ipchains               ########################################### [100%]
[root@timmay download]# ipchains -L
ipchains: Incompatible with this kernel
[root@timmay download]# insmod ipchains
Using /lib/modules/2.4.18-14/kernel/net/ipv4/netfilter/ipchains.o
/lib/modules/2.4.18-14/kernel/net/ipv4/netfilter/ipchains.o: init_module: Device
or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
[root@timmay download]# ipchains -L
ipchains: Incompatible with this kernel
[root@timmay download]#

--------------------------------------------------------------------------------------------------------------------
DMESG Output




Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2
20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
128MB LOWMEM available.
On node 0 totalpages: 32768
zone(0): 4096 pages.
zone(1): 28672 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=linux ro BOOT_FILE=/boot/vmlinuz-2.4.18-14
root=LABEL=/
Initializing CPU#0
Detected 199.436 MHz processor.
Speakup v-1.00 CVS: Tue Jun 11 14:22:53 EDT 2002 : initialized
Console: colour VGA+ 80x25
Calibrating delay loop... 395.94 BogoMIPS
Memory: 124808k/131072k available (1326k kernel code, 4852k reserved, 999k data,
212k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount cache hash table entries: 2048 (order: 2, 16384 bytes)
ramfs: mounted with options: <defaults>
ramfs: max_pages=15729 max_file_pages=0 max_inodes=0 max_dentries=15729
Buffer cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: Before vendor init, caps: 0000f9ff 00000000 00000000, vendor = 0
CPU: L1 I cache: 8K, L1 D cache: 8K
CPU: L2 cache: 256K
CPU: After vendor init, caps: 0000f9ff 00000000 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:     After generic, caps: 0000f9ff 00000000 00000000 00000000
CPU:             Common caps: 0000f9ff 00000000 00000000 00000000
CPU: Intel Pentium Pro stepping 07
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfd901, last bus=0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Cannot allocate resource region 4 of device 00:07.1
Limiting direct PCI/PCI transfers.
Activating ISA DMA hang workarounds.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
speakup:  initialized device: /dev/synth, node (MAJOR 10, MINOR 25)
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.1 Flags 0x03 (Driver version 1.16)
Starting kswapd
VFS: Diskquotas version dquot_6.5.0 initialized
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS2 at 0x03e8 (irq = 4) is a 16550A
ttyS3 at 0x02e8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
oprofile: mapping APIC.
oprofile: enabled local APIC. Err code 00000000
oprofile 0.2 loaded, major 254
block: 240 slots per queue, batch=60
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX3: IDE controller on PCI bus 00 dev 39
PCI: Enabling device 00:07.1 (0000 -> 0001)
PIIX3: chipset revision 0
PIIX3: not 100% native mode: will probe irqs later
PIIX3: neither IDE port enabled (BIOS)
PDC20262: IDE controller on PCI bus 00 dev 88
PDC20262: chipset revision 1
PDC20262: not 100% native mode: will probe irqs later
PDC20262: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
    ide2: BM-DMA at 0xff00-0xff07, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xff08-0xff0f, BIOS settings: hdg:pio, hdh:pio
hde: WDC WD200EB-11BHF0, ATA DISK drive
ide2 at 0xfff0-0xfff7,0xffe6 on irq 9
blk: queue c03c068c, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03c068c, I/O limit 4095Mb (mask 0xffffffff)
hde: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(33)
ide-floppy driver 0.99.newide
Partition check:
 hde: [PTBL] [2434/255/63] hde1 hde2 hde3
FDC 0 is a National Semiconductor PC87306
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 129k freed
VFS: Mounted root (ext2 filesystem).
Journalled Block Device driver loaded
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: ide2(33,2): orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 837129
EXT3-fs: ide2(33,2): 1 orphan inode deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 212k freed
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide2(33,2), internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.18, 14 May 2002 on ide2(33,1), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
IA-32 Microcode Update Driver: v1.11 <tigran@veritas.com>
microcode: CPU0 updated from revision 197 to 198, date=12101996
microcode: freed 2048 bytes
parport0: PC-style at 0x378 [PCSPP]
ohci1394: pci_module_init failed
ip_tables: (C) 2000-2002 Netfilter core team
NET4: Linux IPX 0.47 for NET4.0
IPX Portions Copyright (c) 1995 Caldera, Inc.
IPX Portions Copyright (c) 2000, 2001 Conectiva, Inc.
Linux Tulip driver version 0.9.15-pre11 (May 11, 2002)
tulip0: no phy info, aborting mtable build
divert: allocating divert_blk for eth0
eth0: Macronix 98715 PMAC rev 37 at 0xc8879800, 00:80:C6:E8:FE:95, IRQ 9.
divert: allocating divert_blk for eth1
eth1: ADMtek Comet rev 17 at 0xc887bc00, 00:03:6D:13:B6:B5, IRQ 5.
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
Linux Tulip driver version 0.9.15-pre11 (May 11, 2002)
tulip0: no phy info, aborting mtable build
divert: allocating divert_blk for eth0
eth0: Macronix 98715 PMAC rev 37 at 0xc885d800, 00:80:C6:E8:FE:95, IRQ 9.
divert: allocating divert_blk for eth1
eth1: ADMtek Comet rev 17 at 0xc885fc00, 00:03:6D:13:B6:B5, IRQ 5.
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
Linux Tulip driver version 0.9.15-pre11 (May 11, 2002)
tulip0: no phy info, aborting mtable build
divert: allocating divert_blk for eth0
eth0: Macronix 98715 PMAC rev 37 at 0xc885d800, 00:80:C6:E8:FE:95, IRQ 9.
divert: allocating divert_blk for eth1
eth1: ADMtek Comet rev 17 at 0xc885fc00, 00:03:6D:13:B6:B5, IRQ 5.
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
Linux Tulip driver version 0.9.15-pre11 (May 11, 2002)
tulip0: no phy info, aborting mtable build
divert: allocating divert_blk for eth0
eth0: Macronix 98715 PMAC rev 37 at 0xc885d800, 00:80:C6:E8:FE:95, IRQ 9.
divert: allocating divert_blk for eth1
eth1: ADMtek Comet rev 17 at 0xc885fc00, 00:03:6D:13:B6:B5, IRQ 5.
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
Linux Tulip driver version 0.9.15-pre11 (May 11, 2002)
tulip0: no phy info, aborting mtable build
divert: allocating divert_blk for eth0
eth0: Macronix 98715 PMAC rev 37 at 0xc885d800, 00:80:C6:E8:FE:95, IRQ 9.
divert: allocating divert_blk for eth1
eth1: ADMtek Comet rev 17 at 0xc885fc00, 00:03:6D:13:B6:B5, IRQ 5.
mice: PS/2 mouse device common for all mice
Comment 1 Mike A. Harris 2002-10-09 19:01:45 EDT
ipchains works perfectly with Red Hat Linux.  Your problem is completely
to do with properly configuring your system.  This is not a bug.

Hint: You can use either ipchains *or* iptables.  Not both.

For detailed help with configuring ipchains or iptables, please consult
the Red Hat Linux official documentation, or one of the Red Hat
mailing lists.

Note You need to log in before you can comment on or make changes to this bug.