Bug 754987 - Missing apcupsd support in halt script
Missing apcupsd support in halt script
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: EasyFix, Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 08:50 EST by Robert Scheck
Modified: 2013-04-13 08:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 08:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
initscripts-8.45.38-apcupsd.patch (684 bytes, patch)
2011-11-18 08:50 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2011-11-18 08:50:10 EST
Description of problem:
Currently /etc/rc.d/init.d/halt has the necessary section to support "nut" but 
not the bits needed for apcupsd.

Version-Release number of selected component (if applicable):
initscripts-8.45.38-2.el5

How reproducible:
Everytime

Actual results:
Missing apcupsd support in halt script

Expected results:
Give end users of apcupsd full "out of the box" experience by adding a killpower
section to /etc/rc.d/init.d/halt.

Additional info:
Please use the attached patch or better.
Comment 1 Robert Scheck 2011-11-18 08:50:27 EST
Created attachment 534396 [details]
initscripts-8.45.38-apcupsd.patch
Comment 2 Robert Scheck 2011-11-18 08:55:19 EST
I have cross-filled case 00564057 in the customer portal at the Red Hat Network.
Comment 3 Bill Nottingham 2011-11-22 11:49:21 EST
This is not changing for RHEL 5 at this point in time.
Comment 7 Lukáš Nykrýn 2013-03-11 08:01:02 EDT
I am sorry, but it is now too late in the RHEL-5 release cycle.
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first
production phase 2 [1] release of RHEL-5. Since phase 2 we'll be
addressing only security and critical issues.
This one issue is fixed in RHEL-6 therefore I am closing the bug as
NEXTRELEASE.

[1] https://access.redhat.com/support/policy/updates/errata/
Comment 8 Robert Scheck 2013-04-13 08:08:45 EDT
Lukáš, your copy & paste standard reply is just crap, sorry. You, Red Hat, did 
refuse this RHBZ even with a case in the Red Hat Portal about 1.5 years before 
for IMHO strange reasons from a customer perspective.

Note You need to log in before you can comment on or make changes to this bug.