Bug 75521 - rpmbuild does not create binary RPMs on systems upgraded to 8.0
rpmbuild does not create binary RPMs on systems upgraded to 8.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 10:58 EDT by Rick Moseley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 11:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Moseley 2002-10-09 10:58:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

Description of problem:
On a system upgraded from RH 7.3 to 8.0 the "rpmbuild -ba" works fine up until a
binary RPM is supposed to be created and then it does not create a binary RPM
but rather stops without any errors being listed.  If the redhat-rpm-config
package is added to the system rpmbuild works fine then.  On systems that have
8.0 installed outright (not upgraded) rpmbuild works fine since the
redhat-rpm-config package is installed as part of the system load.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade a system from 7.3 to 8.0
2.use the rpmbuild -ba command on a source RPM to create a binary RPM
3.watch the output....you will NOT see anything resembling the following output:

Wrote: /usr/src/redhat/SRPMS/eclipse-linux-gtk-2.1-8.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/eclipse-linux-gtk-2.1-8.i386.rpm

4.  Look in the /usr/src/redhat/RPMS/* directories and you will NOT find any
binary RPMs
	

Actual Results:  No binary RPM's were built.

Expected Results:  Binary RPMs should have been built.

Additional info:
Comment 1 Jeff Johnson 2002-10-09 11:16:08 EDT
Can you append the full output of the failed build? Thanks.
Comment 2 Jeff Johnson 2002-10-09 12:37:19 EDT
Here's your error message:

Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/eclipse-linux-gtk-buildroot
error: Installed (but unpackaged) file(s) found:
   /usr/lib/eclipse/ChangeLog

Either install the redhat-rpm-config package or
(equivalently) set the macro in /etc/rpm/macros
or ~/.rpmmacros (text from /usr/lib/rpm/macros):

#
# Should unpackaged files in a build root terminate a build?
#
# Note: The default value should be 0 for legacy compatibility.
%_unpackaged_files_terminate_build      1

#
# Should missing %doc files in the build directory terminate a build?
#
# Note: The default value should be 0 for legacy compatibility.
%_missing_doc_files_terminate_build     1





Note You need to log in before you can comment on or make changes to this bug.