Bug 755226 - Fedora 16 fails to boot on HP ProBook 4430s and IBM Thinkpad T400
Summary: Fedora 16 fails to boot on HP ProBook 4430s and IBM Thinkpad T400
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-19 19:13 UTC by Nolan Leasy
Modified: 2013-01-10 06:41 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-07-19 21:35:01 UTC


Attachments (Terms of Use)

Description Nolan Leasy 2011-11-19 19:13:53 UTC
Description of problem:

After performing a clean normal install onto both standard HDD and USB flash drive, Fedora 16 fails to boot in both cases on the HP ProBook 4430s.  Then restored a clean Fedora 15 image onto the USB flash drive and that boots normally.  After upgrading the Fedora 15 install to Fedora 16, without modifying the boot loader, it again fails to boot on either the HP ProBook or the Thinkpad.

On the HP ProBook, the Fedora 16 fails with standard boot or using the UEFI option.


Version-Release number of selected component (if applicable):

16


How reproducible:

Boot attempt from HDD or USB.


Steps to Reproduce:
1. Install or upgrade to Fedora 16.
2. Reboot

  
Actual results:

Infinite loop back to BIOS, in the case of clean Fedora 16 install on HDD.  Missing file error message in the case of Fedora 16 install on USB.


Expected results:

Normal boot.


Additional info:

All versions of Fedora have booted normally on these systems.  This is the first Fedora release that has failed to boot.  On the HP ProBook, the Fedora 16 fails with standard boot or using the UEFI option.

Strongly suspect the new GPT format. (?)

Comment 1 Richard W.M. Jones 2011-11-19 19:46:29 UTC
Fix component.

Comment 2 Bill Nottingham 2011-11-21 20:59:58 UTC
What happens if you install with 'nogpt'?

Comment 3 Nolan Leasy 2011-11-22 16:07:49 UTC
Using the 'nogpt' argument at the install command line does create an 'msdos' partition table and F16 boots successfully on the HP ProBook 4430s.  I assume that it will boot on the Thinkpad as well.

Installed using a mounted DVD ISO, the following command line and selected the standard (non-test) updates at the install GUI:

> vmlinuz initrd=initrd.img repo=ftp://192.168.1.20/pub/inst/Disk1 nogpt

Recommend setting msdos as the default partition table format or giving an option on the disk formatting screen until the BIOS developers catch up.  The average user should not have to deal with the installer command line.

Comment 4 Foampile 2012-01-20 07:34:40 UTC
I am having this issue with F16 on a Lenovo Thinkpad 520, which does have a GPT/EFI disk.  Tried nogpt option as well as making the GPT device bootable with fdisk (both suggested at http://fedoraproject.org/wiki/Common_F16_bugs#Some_systems.2C_particularly_Apple_Macs.2C_cannot_boot_GPT-labelled_disks) but it did not work.  Basically, the Anaconda install goes through fine without a single hickup, then the system can't boot from HDD, returning to the boot order screen to pick another device to boot from.  If I put the LiveUSB back in (which is how I had installed it), it goes back into the install process and the STDOUT log displayed upon the boot and before the new install indicates that some g_hash_table != NULL assertion is failing, which i guess means that it is NULL.  i have no clue what this means cause i didn't know how to pause the process at that stage to examine the STDOUT.

Comment 5 Foampile 2012-01-20 07:37:22 UTC
also, a huge thread on Fedora i initiated about this and going now into 72 hrs:

http://forums.fedoraforum.org/showthread.php?p=1548003#post1548003

thanks

Comment 6 Foampile 2012-01-20 07:47:42 UTC
another related thread:  https://bugzilla.redhat.com/show_bug.cgi?id=752063

Comment 7 Brian Lane 2012-01-20 17:45:11 UTC
On Thinkpads msdos should be used automatically. Please attach the logs from /tmp/*log of the failed install to this bug as individual plain/text attachments so we can get a look at what's going on.

Comment 8 Foampile 2012-01-20 19:19:26 UTC
thanks, Brian

how do i access /tmp/log before the OS is installed?  do i just go into the shell from Anaconda by hitting ctrl-alt-F2 like i did to use fdisk and then ctrl-F6 to go back to GUI installer?

thanks

Comment 9 Brian Lane 2012-01-20 19:41:18 UTC
Yes. The best time is after the install looks like it finished, but before rebooting.

Comment 10 Foampile 2012-01-20 19:48:08 UTC
thanks, Brian.  i am busy with something else right now, will get back this evening.

your help is appreciated

Comment 11 Smittix 2012-02-24 09:17:50 UTC
I am having the same problem on a Samsung NP-RF11-A02DX.

Strange thing is when the computer posts there is a key you can press (F4) That would normally boot the Samsung recovery partition.

If I press this then F16 Boots as expected. If I don't press this then I get boot errors and no Grub at all.

I have also tried UEFI Enabled and Disabled.

I am Just trying the nogpt option to see if that works as it should.

Comment 12 Jesse Keating 2012-07-19 21:35:01 UTC
We don't do gpt by default any more with F17 so this problem should "go away".  We can't really fix the hardware platform.


Note You need to log in before you can comment on or make changes to this bug.