Bug 75527 - "rpm --redhatprovides" DO NOT FUNCTION!
"rpm --redhatprovides" DO NOT FUNCTION!
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 11:32 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 12:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-09 11:32:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --redhatprovides sendmail
2.
3.
	

Actual Results:  no package provides sendmail

Expected Results:  sendmail-8.12.5-7

Additional info:

1. "rpmdb-redhat-8.0-0.20020910.i386.rpm" IS INSTALLED.
2. "rpm --redhatprovides" SHOULD looks into "/usr/lib/rpmdb/i386-redhat-linux/" 
BUT it looks into "/usr/lib/rpmdb/i686-redhat-linux/".
Comment 1 Jeff Johnson 2002-10-09 11:43:57 EDT
Yes. I believe the problem is fixed by either
	a) installing the redhat-rpm-config package
	b) installing the final rpm-4.1 release from
		ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x

If one of the above doesn't fix, reopen this bug, and I'll
give you a configuration workaround.
Comment 2 Need Real Name 2002-10-09 12:29:18 EDT
I need to install rpm-4.1-9 AND uninstall redhat-rpm-config to make it work.

But another problem is:

[root@rh8 root]# rpm --redhatprovides sshd
no package provides sshd

[root@rh8 root]# rpm --redhatprovides openssl
openssl-0.9.6b-29
Comment 3 Need Real Name 2002-10-09 12:42:08 EDT
Oh sorry that I haven't type the path.
I made it.

[root@rh8 root]# rpm --redhatprovides /usr/sbin/sshd
openssh-server-3.4p1-2
Comment 4 Jeff Johnson 2002-10-09 14:11:21 EDT
This appears fixed.

Note You need to log in before you can comment on or make changes to this bug.