Bug 75531 - rpm segfaults when installing/upgrading rpms.
Summary: rpm segfaults when installing/upgrading rpms.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-09 16:23 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 16:23:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-09 16:23:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
rpm crashes when installing/upgrading certain rpms all at once.

Version-Release number of selected component (if applicable):  rpm-4.1-1.06


How reproducible:
Always

Steps to Reproduce:
In this example I was installing enlightenment window manager on the system (I
know it's old, but I like it).  I saw this problem when installing a few other
programs as well on various computers with a fairly unmodified configuration.

1.  Download the following rpms from rpmfind.net and put them in their own
directory:
enlightenment-0.16.5-1.i386.rpm  (I got this one from the enlightenment.org website)
enlightenment-conf-0.15-9.i386.rpm
fnlib-0.5-1.i386.rpm
fnlib-devel-0.5-1.i386.rpm
imlib-1.9.13-3.7.x.i386.rpm

2.  Type the following command:  rpm -Uvh *.rpm --nodeps
3.  rpm crashes with a segfault.
4.  Installing each of the rpms individually instead of grouped together does
not yield a segfault.


Additional info:

When installing these same rpms in the exact same manor on RedHat 7.3 everything
is installed as expected.  I also tried passing rpm the --rebuilddb option which
didn't affect anything.

Comment 1 Jeff Johnson 2002-10-09 18:46:15 UTC
You're downloading packages (fnlib at least)
from 1999 produced by rpm-3.0. Rebuild from
src.rpm's if you want these bits
installed.


Note You need to log in before you can comment on or make changes to this bug.