Bug 75533 - error in Gnome settings daemon dialog
error in Gnome settings daemon dialog
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: GConf2 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 13:03 EDT by Eric Bourque
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-03 11:55:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Bourque 2002-10-09 13:03:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Every time I log in, I get an error dialog which says:

There was an error starting the GNOME Settings Daemon.

...

the last message was:

Failed to activate 'OAFIID:GNOME_SettingsDaemon

GNOME will still try to restart the Settings Daemon next time you log in.

This happens on several systems I have installed RH 8.0 on.

/usr/libexec/gconfd-2 9 is running

relevant entries from /var/log/messages after logging in as root (I see the
warning when logging in as a user too):

Oct  9 12:34:32 trane gdm(pam_unix)[879]: session opened for user root by (uid=0)
Oct  9 12:34:33 trane gconfd (root-1265): starting (version 1.2.1), pid 1265
user 'root'
Oct  9 12:34:33 trane gconfd (root-1265): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config source at
position 0
Oct  9 12:34:33 trane gconfd (root-1265): Resolved address
"xml:readwrite:/root/.gconf" to a writable config source at position 1
Oct  9 12:34:33 trane gconfd (root-1265): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at
position 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in using a gnome session.
2. Error dialog pops up.
3.
	

Additional info:
Comment 1 Eric Bourque 2002-10-28 11:33:55 EST
While trying to fix another error, this one magically seems to have been fixed.
My install was suddenly missing control-center (which I noticed when the "Change
desktop background" stopped functioning. Installing control-center,
xscreensaver, and fortune-mod solved this particular problem too. Why
control-center suddenly disappeared is another thing ...
Comment 2 Gregory Haggquist 2002-11-03 11:55:49 EST
I have the same problem, however the above stated programs are installed on my
system (see rpm output below). Any other suggestions as to how to fix the problem?

gwh@yma: ~ <343> rpm -q control-center
control-center-1.4.0.5-10.ximian.2
gwh@yma: ~ <344> rpm -q xscreensaver
xscreensaver-4.05-6
gwh@yma: ~ <345> rpm -q fortune-mod
fortune-mod-1.0-24

gwh@traptek.com
Comment 3 Havoc Pennington 2002-11-03 12:03:26 EST
You have an old Ximian control-center, not the 8.0 control-center. 
See the release notes comments about how to successfully upgrade 
a system with Ximian installed. You're "on your own" to some extent there but 
the release notes do tell you how to make it work.

It looks like the problem here is not with gnome, so closing bug. 
If you narrow down how control-center got uninstalled, maybe file a bug against
the relevant package.

Note You need to log in before you can comment on or make changes to this bug.