This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 755340 - LVM2.02.88 wrong value of mandir and infodir in make.tmpl.in
LVM2.02.88 wrong value of mandir and infodir in make.tmpl.in
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alasdair Kergon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 14:51 EST by stlman
Modified: 2011-11-20 15:56 EST (History)
12 users (show)

See Also:
Fixed In Version: 2.02.89
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-20 15:53:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Make --mandir and --infodir take effect (452 bytes, patch)
2011-11-20 14:51 EST, stlman
no flags Details | Diff

  None (edit)
Description stlman 2011-11-20 14:51:36 EST
Created attachment 534680 [details]
Make --mandir and --infodir take effect

Description of problem:

The --mandir and --infodir parameters to configure script do not affect build process because mandir and infodir variables in the make.tmpl.in file are erroneously defined.

Version-Release number of selected component (if applicable):
2.02.88

How reproducible:
Always

Steps to Reproduce:
0. mkdir /tmp/pkg-lvm2
1. configure --mandir=/usr/man && make && make install DESTDIR=/tmp/pkg-lvm2
  
Actual results:
Man pages installed in /tmp/pkg-lvm2/usr/share/man.

Expected results:
Man pages installed in /tmp/pkg-lvm2/usr/man.
Comment 1 Alasdair Kergon 2011-11-20 15:53:29 EST
Fixed upstream for next release, thanks.
Comment 2 Alasdair Kergon 2011-11-20 15:56:51 EST
(BTW I changed the datarootdir definition too to avoid getting $(DESTDIR) doubled up when embedded.)

Note You need to log in before you can comment on or make changes to this bug.