Bug 75565 - Installer GUI mode shows corrupted display on Thinkpad 760XL
Installer GUI mode shows corrupted display on Thinkpad 760XL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 17:54 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version: Fedora Core 1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 03:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-09 17:54:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On an IBM Thinkpad 760XL the installer incorrectly detects the video and 
display panel, then proceeds to launch a horribly corrupted screen.  The screen
appears as many shimmering colored lines.  External video will not work for X at
that time.  Text Terminals all work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Since this model has no bootable cdrom and cannot have a cdrom and floppy in
the machine simultaeously you must create a 50MB DOS partition  with cdrom
drivers and copy the DOSUTILs directory to it from the CD, then disable the DOS
cdrom drivers and boot with AUTOBOOT.BAT from the DOS Partition.
2.After launching AUTOBOOT.BAT skip past the CD test utility
3.At this point GUI mode provides you with a useless and corrupt display

	

Actual Results:  The display was corrupted so setup could not continue.

Expected Results:  We expected a GUI setup screen to continue setup as worked in 7.2

Additional info:

In Redhat 7.3 the Installer worked in GUI mode but the coruuption occured after
setup was done.
This install has been attempted on several 760XL's with multiple sets of media.
This is a very common Thinkpad and it ran RedHat 7.2 well.  Please fix this.
Comment 1 Jeremy Katz 2002-10-14 11:00:46 EDT
What is the video adapter used in the 760 and also what is the native LCD panel
resolution?
Comment 2 Need Real Name 2002-10-14 13:01:42 EDT
Trident 9385 Video @ 800x600 and 16bit
As I said under RedHat 7.2 it Autodetected and worked perfectly with a default laptop install.
Comment 3 Michael Fulbright 2002-10-24 14:11:08 EDT
If you switch to VC2 (cntl-alt-f2) and run

less /tmp/anaconda.log

and page through it, can you see what the installer probed as the videocard and
monitor?
Comment 4 Need Real Name 2002-10-27 18:04:54 EST
Video  Card: TGUI9660 (Generic)
Monitor Type: Unable to probe.

Both wrong, yet both were detected correctly under 7.2.
Comment 5 Michael Fulbright 2002-11-01 12:56:40 EST
Looks like the hwdata is getting the wrong VGA card.

Comment 6 Bill Nottingham 2002-11-01 14:27:28 EST
Can you post the output of lspci?
Comment 7 Need Real Name 2002-11-11 17:37:21 EST
Here is the dump

00:00.0 Host bridge: Intel Corp. 430MX - 82437MX Mob. System Ctrlr (MTSC) & 82438MX Data Path (MTDP) (rev 02)
00:01.0 ISA bridge: Intel Corp. 82371FB PIIX ISA [Triton I] (rev 02)
00:02.0 CardBus bridge: Texas Instruments PCI1130 (rev 04)
00:02.1 CardBus bridge: Texas Instruments PCI1130 (rev 04)
00:03.0 VGA compatible controller: Trident Microsystems TGUI 9660/938x/968x (rev d3)

Steve
Comment 8 Bill Nottingham 2004-01-29 01:07:51 EST
That's the correct card; looks like an X driver bug.
Comment 9 Mike A. Harris 2004-01-29 03:36:00 EST
We don't support 8.0 anymore, however this problem has been solved
for quite a long time in RHL 9 I believe.  I'm going to close it
for now as CURRENTRELEASE (Fedora Core 1), however reopen it if
the problem persists in Fedora Core 1 or RHEL 3.

Note You need to log in before you can comment on or make changes to this bug.