Bug 75571 - Kernel Compil Error
Kernel Compil Error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 18:20 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 08:09:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-09 18:20:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
Trying to compile the new kernel 2.4.19 under the redhat 8.0, It doesn't not
even make dependencies "make dep" 'cos it can't find the file stdarg.h which IS
installed on my system.
To resolv the bug I had to change my lang global variable!
export LANG=C
The last one with which it does not compil the kernel was:
LANG="fr_FR.UTF-8"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install The redhat 8.0
2.Choose Francais/French as language
3.Install all the packages needed to compil a kernel
4.Download the kernel 2.4.19 and try to compil...
	

Actual Results:  Dans le fichier inclus ` partir de
/usr/src/linux-2.4.19/include/linux/wait.h:13,
` partir de /usr/src/linux-2.4.19/include/linux/fs.h:12,
` partir de /usr/src/linux-2.4.19/include/linux/capability.h:17,
` partir de /usr/src/linux-2.4.19/include/linux/binfmts.h:5,
` partir de /usr/src/linux-2.4.19/include/linux/sched.h:9,
` partir de /usr/src/linux-2.4.19/include/linux/mm.h:4,
` partir de sched.c:23:
/usr/src/linux-2.4.19/include/linux/kernel.h:10:20: stdarg.h: Aucun fichier ou
ripertoire de ce type
Dans le fichier inclus ` partir de /usr/src/linux-2.4.19/include/linux/wait.h:13,
` partir de /usr/src/linux-2.4.19/include/linux/fs.h:12,
` partir de /usr/src/linux-2.4.19/include/linux/capability.h:17,
` partir de /usr/src/linux-2.4.19/include/linux/binfmts.h:5,
` partir de /usr/src/linux-2.4.19/include/linux/sched.h:9,
` partir de /usr/src/linux-2.4.19/include/linux/mm.h:4,
` partir de sched.c:23:
/usr/src/linux-2.4.19/include/linux/kernel.h:73: erreur d'analyse syntaxique
avant + va_list ;
/usr/src/linux-2.4.19/include/linux/kernel.h:73: AVERTISSEMENT: diclaration de
fonction n'est pas un prototype
/usr/src/linux-2.4.19/include/linux/kernel.h:76: erreur d'analyse syntaxique
avant + va_list ;
/usr/src/linux-2.4.19/include/linux/kernel.h:76: AVERTISSEMENT: diclaration de
fonction n'est pas un prototype
/usr/src/linux-2.4.19/include/linux/kernel.h:80: erreur d'analyse syntaxique
avant + va_list ;
/usr/src/linux-2.4.19/include/linux/kernel.h:80: AVERTISSEMENT: diclaration de
fonction n'est pas un prototype
make[2]: *** [sched.o] Erreur 1
make[2]: Quitte le ripertoire `/usr/src/linux-2.4.19/kernel'
make[1]: *** [first_rule] Erreur 2
make[1]: Quitte le ripertoire `/usr/src/linux-2.4.19/kernel'
make: *** [_dir_kernel] Erreur 2 

Expected Results:  It should compil with NO error.

Additional info:

To resolv the bug you have to change your lang global variable!
export LANG=C
instead of using this one: LANG="fr_FR.UTF-8"
Comment 1 yann zinzius 2002-10-10 05:11:47 EDT
This bug report is also valid if you want to compile the kernel 2.4.18-14
provided in the redhat 8.0 cdrom. But it does not affect the compiling of other
softwares.
Comment 2 FRLinux 2002-10-31 07:28:47 EST
I test this as well on a system installed in French which did the same error
whereas a standard English install didn't.
Comment 3 Jakub Jelinek 2002-10-31 07:37:07 EST
That's a kernel bug, not gcc's.
Following line in linux-2.4.*/Makefile:
kbuild_2_4_nostdinc     := -nostdinc $(shell $(CC) -print-search-dirs | sed -ne 's/install: \(.*\)/-I \1include/gp')
should be changed into:
kbuild_2_4_nostdinc     := -nostdinc $(shell LC_ALL=C $(CC) -print-search-dirs | sed -ne 's/install: \(.*\)/-I \1include/gp')
Comment 4 FRLinux 2002-11-04 12:55:15 EST
You mean a RedHat kernel bug right ? Because no other Linux distribution suffers
of the same bug whatsoever (Even changed my default locales to
LANG="fr_FR.UTF-8" to do a test under Debian sid).

Comment 5 Alan Cox 2003-06-05 08:09:20 EDT
This locale dependancy has been fixed upstream in the base kernel now.

Note You need to log in before you can comment on or make changes to this bug.