Bug 755782 - FTBFS on a full (non-Koji) system
FTBFS on a full (non-Koji) system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 21:59 EST by Jan Kratochvil
Modified: 2013-04-30 19:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: tigervnc-1.1.0-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-02 16:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
.spec fix (266 bytes, patch)
2011-11-21 21:59 EST, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2011-11-21 21:59:18 EST
Created attachment 534904 [details]
.spec fix

Description of problem:
Could not rebuild tigervnc on my system.

Version-Release number of selected component (if applicable):
tigervnc-1.1.0-2.fc16

How reproducible:
Always.

Steps to Reproduce:
rpmbuild -bb tigervnc.spec

Actual results:
make[2]: Entering directory `.../tigervnc/f16/tigervnc-1.1.0/unix/xserver/doc'
make[2]: *** No rule to make target `Xserver-spec.xml', needed by `all-am'.  Stop.

Expected results:
Built rpm.

Additional info:
configure is searching for tools to build the doc.
I did not look at which specific rpm I have installed causing it.
Packages should build the same no matter which system packages are installed.
Comment 1 Adam Tkac 2011-11-22 06:35:20 EST
It's better to use mock to successfully build tigervnc locally because X.Org changes often and simple "rpmbuild -bb" usually fails. However thanks for your patch, I will apply it.
Comment 2 Fedora Update System 2011-11-22 09:27:47 EST
tigervnc-1.1.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tigervnc-1.1.0-3.fc16
Comment 3 Fedora Update System 2011-11-22 19:54:36 EST
Package tigervnc-1.1.0-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tigervnc-1.1.0-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16244/tigervnc-1.1.0-3.fc16
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-12-02 16:26:55 EST
tigervnc-1.1.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.