Bug 75605 - UID/GID's over 100000 not supported
UID/GID's over 100000 not supported
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 01:51 EDT by Panu Matilainen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:30:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2002-10-10 01:51:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
redhat-config-users needlessly limits the UID/GID to max of 100000. 32bit UID's
have been supported for a while now so this seems a bit silly. Not that I have
million users here but by default each users UID *is* over 1000000 due to
various reasons.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Launch redhat-config-users
2.Try to add user with UID/GID of 1000000

	

Actual Results:  The UID/GID gets cut down to 100000.

Expected Results:  UID/GID's up to 32bit max value should be accepted.

Additional info:

Easily fixed by changing the xxxSpinButton.set_range(0, 100000) calls to
set_range(0, pow(2, 32)) or similar.
Comment 1 Brent Fox 2002-10-10 15:33:14 EDT
You are right.  I've fixed this in CVS.

QA, please verify the fix with redhat-config-users-1.1.1-3 in dist-8.0.1.
Comment 2 Peter van Egdom 2003-03-12 16:32:10 EST
Fix seems verified in "redhat-config-users-1.1.5-5" on Phoebe 8.0.94.

[root@powermate root]# cat /etc/passwd |grep -i testuser

testuser3:x:1000000:507:testuser3:/home/testuser3:/bin/bash
testuser4:x:10000000:508:testuser4:/home/testuser4:/bin/bash
testuser5:x:100000000:509:testuser5:/home/testuser5:/bin/bash
testuser6:x:1000000000:510:testuser6:/home/testuser6:/bin/bash

When entering UID "10000000000" in redhat-config-users, this gets changed to
4294967296, and the following error appears :

   Traceback (most recent call last):
     File "/usr/share/redhat-config-users/userWindow.py", line 230, in
     on_userWin_ok_button_clicked
       uidNumber = int(self.uidSpinButton.get_value())
   OverflowError: float too large to convert

However, UID "100000" seems to work fine in redhat-config-users.
Comment 3 Brent Fox 2003-05-25 10:30:47 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.