Bug 75607 - apache Segmentation fault possible php-snmp cause
apache Segmentation fault possible php-snmp cause
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: apache (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 03:51 EDT by John Newbigin
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2002-10-10 03:51:57 EDT
Description of Problem:
[Thu Oct 10 16:32:37 2002] [notice] child pid 1200 exit signal Segmentation 
fault (11)

Apache child terminates.  Sometimes the other apache processes continue to run, 
sometimes the server has to be restarted.


Version-Release number of selected component (if applicable):
apache-1.3.22-6
php-4.1.2-7.2.4
php-snmp-4.1.2-7.2.4
ucd-snmp-4.2.5-7.72.0

Other installed php modules
php-mysql-4.1.2-7.2.4
php-ldap-4.1.2-7.2.4
php-imap-4.1.2-7.2.4


How Reproducible:
I have a php script which does a lot of snmpwalk.  About 1 in 50 times apache 
will crash.  (5 times in the past 2 days).


I do not know the exact cause but I am 99% sure it is my snmp page which is 
causeing the problems.  They only started when I started working on the 
script.  I have not found an exact trigger and this is a live web server so I 
am not too keen on crashing it :(

The only snmp calls I make are
snmp_set_quick_print(true);
and snmpwalk.

I can provide the script if anyone wants it.
Comment 1 Joe Orton 2004-09-21 06:31:07 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Comment 2 Joe Orton 2004-09-21 06:39:08 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Comment 3 John Newbigin 2004-09-21 19:39:10 EDT
php-snmp has been removed from RHEL21 so I guess this bug will be
fobbed off again.

[Mon Sep 20 04:02:01 2004] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Mon Sep 20 04:02:01 2004] [notice] Accept mutex: sysvsem (Default:
sysvsem)
[Mon Sep 20 13:25:56 2004] [notice] child pid 30943 exit signal
Segmentation fault (11)
[Mon Sep 20 15:04:47 2004] [notice] child pid 31863 exit signal
Segmentation fault (11)
[Mon Sep 20 17:03:00 2004] [notice] child pid 31505 exit signal
Segmentation fault (11)
[Tue Sep 21 03:10:21 2004] [notice] child pid 10726 exit signal
Segmentation fault (11)
Comment 4 Joe Orton 2004-10-07 12:22:00 EDT
Thanks for reproducing the problem.  Can you obtain a core dump and
backtrace for this issue so that further diagnosis is possible?

To obtain a backtrace from a segfault in an httpd child, add:
                                                                     
                          
   CoreDumpDirectory /tmp

to httpd.conf, and then stop the httpd service.  After starting the
service using:

  # ulimit -c unlimited; apachectl start

                                                                     
                          and waiting for a core dump to trigger, a
backtrace can be obtained using:

# gdb /usr/sbin/httpd /tmp/core.*
...
(gdb) backtrace
Comment 5 RHEL Product and Program Management 2007-10-19 15:25:56 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.